Asus GTX 970 strix SLI not working properly

Hello Guys,
First my Specs:

AMD Fx8350 @ 4,4 GHz
Hyper X Savage 16 GB 2400 MHz @ 2133 MHz
2x Asus Strix GTX 970 SLI
Asus Crosshair V Formular Z
be quiet power zone 1000W psu
Be quiet Dark Base 900 White Limited Edition

So my Problem is:
The Cards are recognize
In Asus GPU Tweak II too and i can Sync them.
I have barely to no performanceboost. Max 10 FPS and a few points more on 3D Mark.

The 2nd one often got GPU boost drops, so they are not running really stable.

The Drivers are up to date. I tried both cards and single the both work properly.

Anyone an Idea?

Thanks
Reply to bellojustin
7 answers Last reply
More about asus gtx 970 strix sli working properly
  1. What temp is the bottom card running at? Are your cards touching in the system?

    Also, did you turn on SLI in the nVidia driver? Keep in mind as well, some games don't support SLI. What are you playing? Did you make sure the game supports SLI, and the option is turned on?
    Reply to Randomdeath
  2. Randomdeath said:
    What temp is the bottom card running at? Are your cards touching in the system?

    Also, did you turn on SLI in the nVidia driver? Keep in mind as well, some games don't support SLI. What are you playing? Did you make sure the game supports SLI, and the option is turned on?


    Thanks for the reply

    The Cards dont Touch anything. The NVIDEA Drivers are enabled.

    I know that there are some Games that doesnt support SLI
    i usually play
    Player Unknown Battlegrounds (Does not support)
    Cities Skylines
    Arma 3
    Counterstrike GO
    The Hunter COTW
    No Man's Buy ----Sky*
    and some other shit like COD MW2, Ark, Darksouls etc....
    but none of these games got more FPS

    and dont forget the benchmarks
    3DMark/Futurmark
    AIDA64
    i get barely more performance.

    oh and the temp
    GPU#1 24-71°
    GPU#2 26-73°
    Reply to bellojustin
  3. I don't mean to make you sound like an idiot, here. I just want to make sure.

    Is your SLI bridge connected firmly onto both cards? Both cards can be detected without the bridge, but until you connect the bridge they wont render together.
    Reply to Randomdeath
  4. Randomdeath said:
    I don't mean to make you sound like an idiot, here. I just want to make sure.

    Is your SLI bridge connected firmly onto both cards? Both cards can be detected without the bridge, but until you connect the bridge they wont render together.


    No Problem man.
    Yes the SLI Bridge is connected properly.
    I switched the Cards too and no effect.
    Could it be because my PSU is only single raiL ? but be quiet says although it works perfect.
    The Voltage on the GPUs looks normal and stable @ around 862 - 1212 mV
    Reply to bellojustin
  5. Single rail vs multi rail PSU's don't make a difference in SLI. Read here: http://www.overclock.net/t/761202/single-rail-vs-multi-rail-explained

    Now, If your cards are both securely connected to each other, and into the pci-e slots, and both of the 8-pin power connectors are securely connected into both graphics cards...

    One of your cards is faulty, or it's software.

    Before returning one or both of the graphics cards, re install windows with one gpu installed. install all the drivers, then turn off your pc and put in the other gpu making double sure everything like sli bridge and power is connected.

    Once the pc is back on, go into the nvidia driver and enable sli, and go into a game and enable sli in game. see what happens
    Reply to Randomdeath
  6. How are your performance based on the charts? BTW, PUBG supports SLI (it's not really optimized) and CSGO does not.
    Reply to cl-justin
  7. what do you mean? and, in csgo sli wont make a difference no matter what. its a cpu based game
    Reply to Randomdeath
Ask a new question Answer

Read More

Asus Gtx SLI Be Quiet!