Boot Device Led on, pc wont boot

Specs:
Mobo- Asus P9x79 le, lga2011 socket
CPU- Intel i7 4930k
psu- evga 650gold
gpu- Geforce gtx 1060, shortened
storage- barracuda 2tb hdd
Cooling- corsair h105 dual fan water cooler
case- corsair

Problem:
My pc has been running fine with this setup for the last 2 weeks. Yesterday I got a Vive VR, set it up, and ran it for a few hours. Afterwards I watched youtube for another hour or two. I then shut my pc down for 3 hours, and when i tried to boot it back up, it wouldnt. My monitor registers no input but works fine with other device. I checked in my pc and the BOOT_DEVICE_LED is on. I tried restarting it a few times to be safe, no change. I unplugged and replugged my hdd's power cable and seta cable, also no effect. When i watch the boot up sequence, the dram led turns on for a few sec, then the vga led for a few sec, then the boot device led, which stays on. The pc just sits with fans running at a stable speed. I listened to the hdd and it runs, i can hear and feel it spinning when i touch it, so i dont think the internal disks or motors are broken. Plugged in usb devices like mouse and keyboard both light up. I checked the processor and it looks fine so i dont think the processor is broken.

Other info:
I had tried this setup with another motherboard that turned out not to support my cpu earlier. It therefore couldnt post and would shut down a few seconds after being turned on. Therefore, since my pc turns on and stays on, just with the boot device led on and unable to connect to a display, i think it is posting but unable to run bios. Not sure though
Reply to Tyranny777
No answers Last reply
More about boot device led wont boot
Ask a new question Answer

Read More

Boot Devices