is my h100i v2 faulty?

i recently upgraded my pc i wanted to liquid cool my cpu for awhile as i thought fan cooling wasnt as effective but from what i can see fan cooling isnt so different from liquid cooling i mean i get the same temps when gaming around 50-70c sometimes the highest it well jump up to is 80c and quickly back down to mid 60's im not sure if i installed right? than again if i didnt im sure it would of turned off by now? i plugged it into the cpu fan header and i plugged the 2 fans into the Y splitter and for some reason the corsair link app doesnt want to detect my liquid cooler due to signature enforcement so i had to disable it and go back into corsair link to mess with the h100i v2 i set the fans to max and i set the pump to performance sadly my games wont work while signature enforcement is disabled so i had to restart my rig wich re enables it i did notice some difference between fan and liquid cooling with fan the temps are 29-31c and with liquid cooling with the room temp somewhat on the cool side i left the window open the temps were 25 -26c mind you the room will heat up when i close the window with that said the temps are 29-31 my pc specs are listed down below if these temps are normal if im not sapose to be getting these temps let me know thanks


PC SPECS

Motherboard: ASUS ROG Maximus IX Hero LGA1151 ATX Motherboard

CPU PROCCESSOR: INTEL CORE I7-6700K 4.0 GHz

CPU COOLER: CORSAIR Hydro Series H100i v2 Extreme Performance Liquid CPU Cooler

RAM MEMORY: CORSAIR Vengeance LPX 16GB DDR4 3000MHz

SSD: CRUCIAL MX200 500GB

HARDDRIVE: SEAGATE BARRACUDA 2TB 7200RPM
SEAGATE BARRACUDA 3TB 7200RPM

VIDEO CARD: EVGA GTX980 FTW ACX 2.0 4GB 2 WAY SLI

POWER SUPPLY: 1300W EVGA SUPERNOVA G2 80 GOLD+

CASE: FRACTAL DESIGN DEFINE R5 BLACK WINDOW
Reply to 11blackjack11
No answers Last reply
More about h100i faulty
Ask a new question Answer

Read More

Water Cooling Cooling Fan CPUs