Solved

Intel motherboard and amd card

I have an intel dq67sw mother board with an his 7870 2gb iceq turbo graphics card. It boots up but doesn’t show a display. It also makes this loud beep noise. Can somebody please get me advice? Thank you for your time.
37 answers Last reply Best Answer
More about intel motherboard amd card
  1. MERGED QUESTION
    Question from warmachineandrew : "Intel motherboard and amd card."

    warmachineandrew said:
    I have an his 7870 2gb iceq turbo card and an intel dq67sw motherboard. I turn the computer on and it boots on with no display and gives a loud beep. Can somebody please give me advice? Thank you for your time.
  2. Do you try onboard intel iGPU to boot the PC yet? If the PC can boot, then:
    1) What PSU do you have?
    2) Do you test the hd7870 in other PC to see it works or not?
    3) Do you try set the graphics setting in the BIOS, make sure the PC boot from discrete GPU instead the onboard one.
    Also update the MB BIOS, if you can find it from intel site.
  3. I have an intel e3-1220 cpu and I can’t do that either because it also just gives a loud beep when I try to do it. I have gotten it to boot up with an nvidia gt530 though. The gt530 doesn’t have external power while the 7870 does. My his 7870 card did work in a dell Inspiron 570
  4. And you said the PC will give the loud beep, check here for the beep codes for intel MB. https://www.intel.com/content/www/us/en/support/boards-and-kits/000005473.html

    Also you can boot the pc with gt530, but not the hd7870, what PSU do you have?
  5. Yes it gives 4 loud beeps then doesn’t doo anything other than fans running. It works with a GT530 but not a 7870. I was able to get to the bios and I put it to external only and it still doesn’t work
  6. cin19 said:
    And you said the PC will give the loud beep, check here for the beep codes for intel MB. https://www.intel.com/content/www/us/en/support/boards-and-kits/000005473.html

    Also you can boot the pc with gt530, but not the hd7870, what PSU do you have?
  7. I also have an intel Xeon e3-1220 psu. Psu means processing unit right? It has the beep codes of no card installed or card error. I have used this card in a dell Inspiron 570
  8. PSU= power supply unit, because your PC can boot with gt530, but not with hd7870, and you said you tested the HD7870, which works fine. So that means your PSU may not handle the HD7870, or the BIOS setting is not right.
  9. My power supply is a 775w mi pc mi-x8775c psu
  10. The problem is most likely from the PSU. Before you buy other PSU, use the PSU from dell Inspiron 570 to see you can boot the PC or not, because you said the HD7870 worked with dell Inspiron 570.

    If you can boot the PC with that PSU ( from dell Inspiron 570, the dell OEM PSU is good one), you know you will need the new PSU for the HD7870. The wattage, even the 775W, does not tell you the whole story about the PSU, only the good brand is good.

    Here is how to buy a good PSU. http://www.tomshardware.com/t/power-supplies/
  11. cin19 said:
    The problem is most likely from the PSU. Before you buy other PSU, use the PSU from dell Inspiron 570 to see you can boot the PC or not, because you said the HD7870 worked with dell Inspiron 570.

    If you can boot the PC with that PSU ( from dell Inspiron 570, the dell OEM PSU is good one), you know you will need the new PSU for the HD7870. The wattage, even the 775W, does not tell you the whole story about the PSU, only the good brand is good.

    Here is how to buy a good PSU. http://www.tomshardware.com/t/power-supplies/
  12. I booted the card with the Inspiron 570 with the 775watt PSU though, not a dell psu.
  13. And try reseat the RAM on dq67sw, or even use only one stick RAM, if you had two.

    Also check the dq67sw BIOS to see it has the newer one or not. The newer one is [SWQ6710H.86A] https://downloadcenter.intel.com/download/26853/BIOS-Update-SWQ6710H-86A-
  14. cin19 said:
    And try reseat the RAM on dq67sw, or even use only one stick RAM, if you had two.

    Also check the dq67sw BIOS to see it has the newer one or not. The newer one is [SWQ6710H.86A] https://downloadcenter.intel.com/download/26853/BIOS-Update-SWQ6710H-86A-
  15. I have 3 sticks
  16. So the problem may from the RAM, so try only one stick RAM first with the HD7870, if the PC can boot, add other one, in this way you will know the problem is from which stick of the RAM.
  17. cin19 said:
    So the problem may from the RAM, so try only one stick RAM first with the HD7870, if the PC can boot, add other one, in this way you will know the problem is from which stick of the RAM.
  18. Nope, still no screen and beeping twice
  19. How the BIOS version? If the MB has the newer one, that means the HD7870 may have the compatibility problem with that MB.
  20. cin19 said:
    How the BIOS version? If the MB has the newer one, that means the HD7870 may have the compatibility problem with that MB.
  21. It’s the swq6710h.86a.0067.2014.0313.1347 bios
  22. Sorry to bother you but are you still
    there?
  23. cin19 said:
    How the BIOS version? If the MB has the newer one, that means the HD7870 may have the compatibility problem with that MB.
  24. Are you there?
  25. Best answer
    Because your MB had the newer bios, and the HD7870 works fine, also you did use the same PSU with HD7870 in other PC, so the HD7870 may have compatibility problem with dq67sw.
  26. cin19 said:
    Because your MB had the newer bios, and the HD7870 works fine, also you did use the same PSU with HD7870 in other PC, so the HD7870 may have compatibility problem with dq67sw.
  27. What would I need to do to get it working?
  28. Get other model GPU.
  29. cin19 said:
    Get other model GPU.
  30. So I couldn’t change anything in bios?
  31. Because you can use the PC with GT530, so the BIOS should be right. But it is strange, because the Q67 chipset should work with the HD7870.
    But double check the graphic section in the BIOS ( use the gt530 to boot into the BIOS) to see it was set to "auto" or something else.
  32. cin19 said:
    Because you can use the PC with GT530, so the BIOS should be right. But it is strange, because the Q67 chipset should work with the HD7870.
    But double check the graphic section in the BIOS ( use the gt530 to boot into the BIOS) to see it was set to "auto" or something else.
  33. Right now I have it set to external pci graphics as my primary
  34. That setting works too. That means the HD7870 does not work with the dq67sw, I don't know why, Sorry, you have to get other model, I know NVIDIA brand GPU has less problem with the old intel MB.
  35. cin19 said:
    That setting works too. That means the HD7870 does not work with the dq67sw, I don't know why, Sorry, you have to get other model, I know NVIDIA brand GPU has less problem with the old intel MB.
  36. Ok, thank you for your help. Have a nice day
  37. This sucks. I having the same issue I believe.
    Anyone fix this issue?

    I have a DH55TC and I think bios is recent. If anything I am plugging in a HD7570 which is around same age!
    It only posts with my NVIDIA Card GTX 750 (newer)
    I checked all settings in bios and CMOS reset few times.

    I tested the AMD card on newer Coffee Lake Board and posts perfect without issues.
    Seems like intel was a holes with AMD back then, the most common of the AMD cards and no posts?
    It did post few times but would freeze at bios screen. But now I can't get any of the AMD cards to work on it. Works on Coffee Lake board, no issues.

    Later I will test a Supermicro board and tell you if it does the same thing.
    Intel Phone support is completely useless, I tell them I need to talk to someone that knows about THESE boards.
    They just give you someone that knows just basics and only tells you that board is old.
Ask a new question

Read More

Graphics Cards Intel Motherboards