Intel motherboard and amd card

I have an intel dq67sw mother board with an his 7870 2gb iceq turbo graphics card. It boots up but doesn’t show a display. It also makes this loud beep noise. Can somebody please get me advice? Thank you for your time.
Reply to warmachineandrew
36 answers Last reply
More about intel motherboard amd card
  1. MERGED QUESTION
    Question from warmachineandrew : "Intel motherboard and amd card."

    warmachineandrew said:
    I have an his 7870 2gb iceq turbo card and an intel dq67sw motherboard. I turn the computer on and it boots on with no display and gives a loud beep. Can somebody please give me advice? Thank you for your time.
    Reply to cin19
  2. Do you try onboard intel iGPU to boot the PC yet? If the PC can boot, then:
    1) What PSU do you have?
    2) Do you test the hd7870 in other PC to see it works or not?
    3) Do you try set the graphics setting in the BIOS, make sure the PC boot from discrete GPU instead the onboard one.
    Also update the MB BIOS, if you can find it from intel site.
    Reply to cin19
  3. I have an intel e3-1220 cpu and I can’t do that either because it also just gives a loud beep when I try to do it. I have gotten it to boot up with an nvidia gt530 though. The gt530 doesn’t have external power while the 7870 does. My his 7870 card did work in a dell Inspiron 570
    Reply to warmachineandrew
  4. And you said the PC will give the loud beep, check here for the beep codes for intel MB. https://www.intel.com/content/www/us/en/support/boards-and-kits/000005473.html

    Also you can boot the pc with gt530, but not the hd7870, what PSU do you have?
    Reply to cin19
  5. Yes it gives 4 loud beeps then doesn’t doo anything other than fans running. It works with a GT530 but not a 7870. I was able to get to the bios and I put it to external only and it still doesn’t work
    Reply to warmachineandrew
  6. cin19 said:
    And you said the PC will give the loud beep, check here for the beep codes for intel MB. https://www.intel.com/content/www/us/en/support/boards-and-kits/000005473.html

    Also you can boot the pc with gt530, but not the hd7870, what PSU do you have?
    Reply to warmachineandrew
  7. I also have an intel Xeon e3-1220 psu. Psu means processing unit right? It has the beep codes of no card installed or card error. I have used this card in a dell Inspiron 570
    Reply to warmachineandrew
  8. PSU= power supply unit, because your PC can boot with gt530, but not with hd7870, and you said you tested the HD7870, which works fine. So that means your PSU may not handle the HD7870, or the BIOS setting is not right.
    Reply to cin19
  9. My power supply is a 775w mi pc mi-x8775c psu
    Reply to warmachineandrew
  10. The problem is most likely from the PSU. Before you buy other PSU, use the PSU from dell Inspiron 570 to see you can boot the PC or not, because you said the HD7870 worked with dell Inspiron 570.

    If you can boot the PC with that PSU ( from dell Inspiron 570, the dell OEM PSU is good one), you know you will need the new PSU for the HD7870. The wattage, even the 775W, does not tell you the whole story about the PSU, only the good brand is good.

    Here is how to buy a good PSU. http://www.tomshardware.com/t/power-supplies/
    Reply to cin19
  11. cin19 said:
    The problem is most likely from the PSU. Before you buy other PSU, use the PSU from dell Inspiron 570 to see you can boot the PC or not, because you said the HD7870 worked with dell Inspiron 570.

    If you can boot the PC with that PSU ( from dell Inspiron 570, the dell OEM PSU is good one), you know you will need the new PSU for the HD7870. The wattage, even the 775W, does not tell you the whole story about the PSU, only the good brand is good.

    Here is how to buy a good PSU. http://www.tomshardware.com/t/power-supplies/
    Reply to warmachineandrew
  12. I booted the card with the Inspiron 570 with the 775watt PSU though, not a dell psu.
    Reply to warmachineandrew
  13. And try reseat the RAM on dq67sw, or even use only one stick RAM, if you had two.

    Also check the dq67sw BIOS to see it has the newer one or not. The newer one is [SWQ6710H.86A] https://downloadcenter.intel.com/download/26853/BIOS-Update-SWQ6710H-86A-
    Reply to cin19
  14. cin19 said:
    And try reseat the RAM on dq67sw, or even use only one stick RAM, if you had two.

    Also check the dq67sw BIOS to see it has the newer one or not. The newer one is [SWQ6710H.86A] https://downloadcenter.intel.com/download/26853/BIOS-Update-SWQ6710H-86A-
    Reply to warmachineandrew
  15. I have 3 sticks
    Reply to warmachineandrew
  16. So the problem may from the RAM, so try only one stick RAM first with the HD7870, if the PC can boot, add other one, in this way you will know the problem is from which stick of the RAM.
    Reply to cin19
  17. cin19 said:
    So the problem may from the RAM, so try only one stick RAM first with the HD7870, if the PC can boot, add other one, in this way you will know the problem is from which stick of the RAM.
    Reply to warmachineandrew
  18. Nope, still no screen and beeping twice
    Reply to warmachineandrew
  19. How the BIOS version? If the MB has the newer one, that means the HD7870 may have the compatibility problem with that MB.
    Reply to cin19
  20. cin19 said:
    How the BIOS version? If the MB has the newer one, that means the HD7870 may have the compatibility problem with that MB.
    Reply to warmachineandrew
  21. It’s the swq6710h.86a.0067.2014.0313.1347 bios
    Reply to warmachineandrew
  22. Sorry to bother you but are you still
    there?
    Reply to warmachineandrew
  23. cin19 said:
    How the BIOS version? If the MB has the newer one, that means the HD7870 may have the compatibility problem with that MB.
    Reply to warmachineandrew
  24. Are you there?
    Reply to warmachineandrew
  25. Because your MB had the newer bios, and the HD7870 works fine, also you did use the same PSU with HD7870 in other PC, so the HD7870 may have compatibility problem with dq67sw.
    Reply to cin19
  26. cin19 said:
    Because your MB had the newer bios, and the HD7870 works fine, also you did use the same PSU with HD7870 in other PC, so the HD7870 may have compatibility problem with dq67sw.
    Reply to warmachineandrew
  27. What would I need to do to get it working?
    Reply to warmachineandrew
  28. Get other model GPU.
    Reply to cin19
  29. cin19 said:
    Get other model GPU.
    Reply to warmachineandrew
  30. So I couldn’t change anything in bios?
    Reply to warmachineandrew
  31. Because you can use the PC with GT530, so the BIOS should be right. But it is strange, because the Q67 chipset should work with the HD7870.
    But double check the graphic section in the BIOS ( use the gt530 to boot into the BIOS) to see it was set to "auto" or something else.
    Reply to cin19
  32. cin19 said:
    Because you can use the PC with GT530, so the BIOS should be right. But it is strange, because the Q67 chipset should work with the HD7870.
    But double check the graphic section in the BIOS ( use the gt530 to boot into the BIOS) to see it was set to "auto" or something else.
    Reply to warmachineandrew
  33. Right now I have it set to external pci graphics as my primary
    Reply to warmachineandrew
  34. That setting works too. That means the HD7870 does not work with the dq67sw, I don't know why, Sorry, you have to get other model, I know NVIDIA brand GPU has less problem with the old intel MB.
    Reply to cin19
  35. cin19 said:
    That setting works too. That means the HD7870 does not work with the dq67sw, I don't know why, Sorry, you have to get other model, I know NVIDIA brand GPU has less problem with the old intel MB.
    Reply to warmachineandrew
  36. Ok, thank you for your help. Have a nice day
    Reply to warmachineandrew
Ask a new question Answer

Read More

Graphics Cards Intel Motherboards