External HDD Stopped Working/Recognized

Hello,

I have a seagate 8TB expansion desktop drive that failed yesterday. Couple days ago, a particular folder inside the drive was running slow/apps were not able to access it, and when I tried to remove it the HDD failed. It was giving me Code 43 (Set address failed) after trying everything I could find on internet, nothing helped (I tried on multiple PCs, all the same problem). So I decided that maybe the enclosure is the problem, So I opened it and installed it as internal one. If I installed the HDD before booting, the HDD wouldn't initialize, but if I plug it in while system is running, it would show the drive with correct usage stats and folders inside. However, when I try to go to any of the folders inside, the OS either hangs or it shows that folder is empty (even though properties of the drive shows 47% of drive is used). if I try any diagnostic tool, the tool would hang even trying to access it.
Last thing I noticed is that task manager shows the HDD at 100% usage even though nothing is accessing it. I'm not sure what to do and any help is greatly appreciated (there are files there that I need to recover).
Reply to FahadAL
1 answer Last reply
More about external hdd stopped working recognized
  1. Seagate drives are hard enough to recover from, let alone the 8TB models. If your data is of value, you are best to seek professional data recovery assistance before further damaged is caused.
    Reply to DR_Luke
Ask a new question Answer

Read More

External Hard Drive