Problems (possibly) with MSI Gaming M7 (Z170A)

This is my config:

Motherboard: MSI Gaming M7 Z170A
PSU: Aerocool Xpredator 650GM 650W 80 Plus Gold
Drive: 2 x Crucial MX200 250GB SSD in RAID 0
RAM: 4 x Crucial CT8G4DFD8213 2400 8GB
Enclosure: NOX Hummer ZX USB 3.0
CPU: Intel Core i7-6700 3.4GHz
DVD: Asus DRW-24D5MT
Extra bay: Sharkoon Media Reader 3
WiFi: TP-Link Archer T9E AC1900 Wireless Dual Band PCI Express

I tell you the whole story, a little resumed... I think

It was working all good for more than a year with this PC, and suddenly, one day, it stopped. It was while I was near to it, and I could hear how it stopped.

The LEDs were still viewable, but when I tried to boot up the computer, nothing moved. Not even the CPU fan.
I pinpointed at the PSU, so I tried to short-circuit two pins, in order to start the PSU, and it didn't work, so I decided to RMA and I received one new.

After installing the new PSU, I could start the computer, but now only for some seconds, and then it would halt unexpectedly. Not even booting to UEFI. After reinstalling some things, it was only after reinstalling the RAM that I got the computer to boot up correctly. But then another problem...

No bootable devices! Why? I don't know! Let's see in the UEFI the recognized drives..
Only the SATA DVD burner is recognized by the UEFI! Amazing.
I've tried to install other HDD drives, but none of them are recognized (!)
Only the SATA DVD burner is recognized in the end.

One interesting thing is that I have a USB-SATA interface, and I tried the disks in another computer, and it doesn't recognize them! But it does recognize another external HDD. (I tried installing this HDD with the motherboard, also not recognizing it)

This is a bit messy. I was considering on replacing the SSDs, but... Even the new ones wouldn't be recognized, as I am noticing.
I've tried even to attach the same SATA cable of the DVD to the HDD, without success.
I've tried changing mode AHCPI to RAID in the UEFI settings of the motherboard, without success..
Also trying with enabling hotplug on all SATA interfaces...

Also I am facing problems trying UEFI to appear sometimes. For example, the first time I introduced the HDD, it didn't get me to UEFI. And some more times while changing things, it would simply not enter to UEFI.

Thank you very much for all the help you can provide me.
Reply to DrumSergio
No answers Last reply
More about problems possibly msi gaming z170a
Ask a new question Answer

Read More

Gaming MSI-Microstar Aerocool Crucial Motherboards Configuration