Solved

EVGA GTX 1050 2GB on INTEL DH77EB FAN IS WORKING BUT NO DISPLAY

can I use EVGA gtx 1050 2 GB ddr5 for a Intel DH77EB motherboard? I tried to plug in the Gtx 1050 into my MOBO which is Intel DH77EB the graphics card fans are spinning but i dont have display on my monitor, the main board vga is working and other video card are working...... pls help thanks in advance.

it says here http://www.pc-specs.com/gpu/Nvidia/1000_Series/GeForce_... my mobo support GTX 1050 Ti as well so why my screen got no display but the FANS of the GTX1050 is spinning?
Reply to dengkergscott
4 answers Last reply Best Answer
More about evga gtx 1050 2gb intel dh77eb fan working display
  1. You said the mainboard VGA is working. First, in order to use the card you have to use the card. So don't try and use the mainboard. Second, are you really using VGA? Nvidia dropped all support for analog/VGA with the 10 series. You need to use a digital signal. If your monitor supports only VGA you need to get a new monitor, or an ACTIVE VGA to DVI, DP, HDMI, etc adapter. Passive ones won't work.
    Reply to 4745454b
  2. thank you for immediate reply... i used dvi-d to vga adapter from my dvi-d on my gtx1050 going to vga of my monitor.. my monitor has dvi-d aswell do you think i will use that instead of vga?
    Reply to dengkergscott
  3. Best answer
    No need to PM me. I'll get around to getting on here eventually.

    If you use the DVI port on your monitor it should work. I'm sure the issue is the adapter you are using. If it's one that came with a GPU when you bought one awhile ago it won't work. Those are passive adapters and won't work with the 10 series from Nvidia.
    Reply to 4745454b
  4. 4745454b said:
    No need to PM me. I'll get around to getting on here eventually.

    If you use the DVI port on your monitor it should work. I'm sure the issue is the adapter you are using. If it's one that came with a GPU when you bought one awhile ago it won't work. Those are passive adapters and won't work with the 10 series from Nvidia.


    [Resolved]

    Thank you for your help i try to use dvi to dvi wire from my gtx1050 to my monitor and now its working the adapter is the problem which is a dvi to avg.
    Reply to dengkergscott
Ask a new question Answer

Read More

Gtx EVGA Graphics Cards Intel Displays