Hard drive not showing up in BIOS boot options

Hi everyone,
I was tweaking in the bios of my Asus f550cc laptop to prove a friend that you could boot Linux from a flash drive, when I found "realtek controller" in the middle of the boot order.
My curiosity made me try to see what happened if I tried to boot from there, but as soon as I selected it, all the boot options got wiped off.
The hard drive is still recognised by the pc (if i go in "sata configuration" it shows it), but there is no boot option for it.
Searching through the forum, I've seen that a lot of people solved this problem enabling CSM, but the problem is that since all boot options got wiped off, "launch CSM" got locked (it is no longer selectable).
I have also tried to restore defaults, and disable secure boot (the pc re-enables it when it loads the bios).

I don't really know what to do now.

EDIT: i have noticed that i'm no longer marked as admin, but as an user. could this be the problem? and how can i fix it?
Reply to fabio.critone
No answers Last reply
More about hard drive showing bios boot options
Ask a new question Answer