AX370 Gaming K5 + R5 1600: Fresh Windows Install, Can't update

So I just did a clean installation of Windows 10 on my new pc and after installing the motherboard's drivers, I head to Windows Update to make sure my Windows are updated. But it refuses to connect to the server. Trying to fix the problem, I did another clean install of Windows a few hours ago, that only made things worse. Now, I can't connect to Steam or Uplay or even Xsplit, the software that came with my motherboard. Using Chrome to connect to the internet works fine. I tried the Windows Update troubleshooting only to find out the thing I knew, that I cant connect to the server. Any of you have any idea what might be going on and what should I try to do?

Specs:
R5 1600 3.2 GHz
Corsair 16GB 3000Mhz (running at 2666MHz, wouldn't post otherwise)
Gigabyte AX370 Gaming K5 (F2 bios)
Reply to papjim
3 answers Last reply
More about ax370 gaming 1600 fresh windows install update
  1. Check the date and time to see they have right setting or not.

    And may try those steps: http://www.makeuseof.com/tag/resolve-windows-update-problems-5-easy-steps/
    Reply to cin19
  2. Go here and Microsoft will reinstall Windows 10.
    https://www.microsoft.com/en-us/software-download/windows10?ranMID=24542&ranEAID=je6NUbpObpQ&ranSiteID=je6NUbpObpQ-yY7futTvLSE4xjrzOCS1RQ&tduid=

    Microsoft will install a new version of Windows 10, without changing anything in your settings. Problems with Windows Update will be fixed.
    Reply to Calvin7
  3. Have you tried to reinstall the drivers? Which drivers /software did you install?
    Reply to MadOver
Ask a new question Answer

Read More

Gaming Windows Gigabyte Connection Motherboards windows 10 Windows Update