New GTX 1050 TI OC by Zotac Working On My Old Pc With PciE gen 1 But Not on PciE Gen 2

I Recently Bought a Zotac Gtx 1050 Ti Oc...... So I Plugged it In on my Pc With MoBo-ECS H61H2-MV.... With PciE Gen 2..... The Monitor Didnt Displayed anything But also It didnt Say No Display.....
I Tried This Same Card with my Years Old Pc With Gen 1 Pcie And It Worked at the First Time......
What could be the Problem.... Is My New Mobo Not Provinding Enough power To the card by Its PCIE gen 2 bus.... Or Something Wrong with the slot
Also The New Mobo Runs GT-610 very easily
Reply to bittujesus196918
3 answers Last reply
More about gtx 1050 zotac working pcie gen pcie gen
  1. Try disabling the onboard graphics (in BIOS) on the ECS. Then switch the cable to the discrete card after reboot.
    Also what's your power supply model?
    Reply to alceryes
  2. Its Zebronics 450 watts
    Reply to bittujesus196918
  3. Also There are No Onboard Graphics Settings.... Not Even PCI settings
    Reply to bittujesus196918
Ask a new question Answer

Read More

Gtx Zotac