Solved

New HDD makes BIOS hang at splash screen, HDD Light solid.

Short story: after installing a new HDD and failing to install Windows onto it, the PC wont go past BIOS splash screen, and HDD light stays constantly on - but not at full brightness. First 20 seconds after power on, the HDD makes clicking noises, then stops. The PC just hangs for indefinite amount of time with the disk light partially bright, just until I force turn off it. Also it's impossible to get to BIOS settings at all. However, unplugging or replacing the HDD solves the problem.

My specs:

- MoBo: Intel DB75EN
- CPU: Intel Core i5-3450
- RAM: 8 GB
- Old HDD: Seagate BarraCuda 1TB
- New HDD: Western Digital 2TB

What I tried (and actually helped):

- Unplugging HDD
- Changing HDD

So it's clear that the new, just bought HDD causes the mobo to hang. I want to know WHY the new HDD is causing this, but only after the failed install of Windows???

But here's the full story. Recently I had many issues with my PC. Some time ago I noticed that my old 1TB HDD (Seagate) began to die - typical crashes, Windows hangs, etc. And on this disk the Windows became so unstable that drivers fail while booting, PC becomes totally unresponsive, etc.

So I bought a new 2TB HDD (Western Digital). I installed it, but also left an old HDD onboard so I could copy the files to the new one, because the old one was still usable.

I booted live Ubuntu, partitioned the new HDD with gparted - created main partitions - for Windows (300GB), storage (1.4TB), UEFI system partition and some unallocated space for future use.

Then I used the dd tool to clone my data partition to the new disk's storage 1.4TB partition. That went fine, and after a few hours it was done. Of course, read errors occured, because the old HDD was failing after all.

And that was when the strange things started to happen. I tried to use gparted's ntfsfix tool to fix the new disk partition to which the data was cloned because some space in it became unallocated after that operation (because this partition was larger than the old one).

And then gparted CRASHED! It crashed while applying that operation! I waited several mins, then force-closed the program. Then tried again - and same crash occured.

So I thought maybe I will firstly install Windows on the new HDD - after all, that's what I planned to do all along. So I booted Windows from installation media (while both HDDs were SATA'd to the MoBo - the dying one with messed up Windows installation included).

I have ordinarily started a fresh windows installation onto the new drive's partition I made specifically for Windows before. Setup copied files, and the first restart occured. BUT - the old messed up HDD was online. And the BIOS booted from the damn old HDD! The messed up Windows boot manager asked me to select an OS - 2 options were present - both identical 'Windows 7's - I selected randomly just to see what will happen, and of course, I entered the messed up old installation - and the old song again - PC unresponsive, etc.

So I force restarted the PC. And this was the first time the actual problem of the thread occured - the PC entered the BIOS splash screen, and stopped right there, with the "Inter Desktop Board Inside" picture showing on the screen for as long as the PC stays on. And it's impossible to get to the BIOS settings at all - tried pressing F2 in all ways possible - before power on, after, and just-in time, repeatedly, constantly, etc...

And the HDD light: At power on it turns bright for a second, then off, then BIOS splash appears, then the light turns on bright again, and this time for ~20 seconds the HDD makes periodic clicks. After that HDD becomes silent, and the light stays partially bright - about 50% of the brightness.

I repeated this loop several times, and then tried unplugging the HDD from the MoBo - then BIOS went past the splash, and it was possible to get to the settings.

I also tried to plug in the old failing HDD - everything went fine, BIOS let me get to settings and boot. Also tried other good HDD - it works. It's just the NEW HDD that doesn't work.

And when I thing about possible causes of this problem - maybe BIOS starts some kind of disk check because the boot sector got messed up somehow when Windows failed the installation and/or when the partition cloning/fixing happened on Ubuntu? Or maybe the HDD itself got damaged in some crazy way from misbehaving software?

Of course, the disk is on warranty, but we want to fix it by ourselves if it is possible. Or worse - the warranty might be voided because of the things that happened.
Reply to gryllotalpa
2 answers Last reply Best Answer
More about hdd makes bios hang splash screen hdd light solid
  1. Best answer
    Get your system up and running with the good HDD (Disk 0) and without the new HDD.

    Download and have ready WD's diagnostic software.

    Then connect in the new HDD as Disk 1 and run the full WD diagnostics on it.

    Depending on the WD diagnostic results you may or may be able to fix the problem.

    Hopefully, you will have at least identified the problem. Or narrowed the possibilities....
    Reply to Ralston18
  2. Thanks for an answer.

    It turned out that the problem was merely a corrupted Windows bootloader data on the hard drive!

    I hot-plugged the new disk into SATA port while Ubuntu was running, and using gparted I've seen that Windows setup already created boot partitions, so I deleted all Windows partitions, and rebooted - problem is gone!

    Diagnostics showed that the disk was perfectly OK.

    It seems that the problem was with the incomplete Windows bootloader - when BIOS reads from the boot sectors of the disk, it comes across the uncomplete Windows bootloader, starts it, but the bootloader gets into an infinite disk read loop because some necessary componets needed for booting are missing/incomplete.

    So everything is running good now, the Windows had been reinstalled and working.
    Reply to gryllotalpa
Ask a new question Answer

Read More

Hard Drives Windows Light Partition BIOS Splash Screen Intel