Trouble w/ 2TB hdd on MSI 970 Gaming AM3+ mobo

Hiya Guys, I've been jumping all over the interweb trying to find a thread from someone having the same issue that I am on any of the computer forums that I peruse from time to time with no avail, so, I thought I'd bring the issue here to y'all. Here goes :

I recently bought a new 50 inch Toshiba flat screen TV to replace my older 42 inch Vizio flat screen, so I decided to build a new gaming / multimedia Tower to replace my old Asus ROG Rampage ll Core I7 system to pair with the new TV via HDMI. The new system looks something like this :

Full size Cooler Master ATX case :
MSI 970 Gaming (MS-7693) AM3+ Mobo
BIOS version M.40
AMD FX 4300 cpu w/ AMD Wraith cooler
8GB Ripjaw 12800 ram
500 GB Seagate hdd
750 Seagate hdd
1 TB WD hdd
2 TB Seagate hdd
2 TB Nvidia GeForce GTX 770 gpu on 385.41 drivers

The system is loaded and running beautifully on Windows 7 Ultimate 64-bit sp1, but the issue that I'm having is only 3 of my hard drives are showing up in My Computer. The hard drive that's not showing up is my 2TB Seagate barracuda, however all of the hard drives show up in the device manager. All the hard drives also show up in Western digital's acronis True Image software, and seagate's seatools hard drive software. I ran all 4 hdd's thru the SMART test as well as the long and short DST tests and all 4 hard drives are working perfectly.

I've already triple checked all my connections and replaced all my SATA cables and reset the bios back to factory defaults and according to the MSI live update 6 software I'm also running the latest version of the BIOS available and for some unknown reason I still can't getwinders to see my 2 TB hdd, which sucks because it has all my TV show series on it. The funny thing is before I pulled all of these hard drives out of my previous Asus Rampage 2 system, they were all working perfectly, but for some reason this MSI board is being a pita about it, so I thought some of y'all might have a different perspective on things ?. Thanks
Reply to gsbuickman
1 answer Last reply
More about trouble 2tb hdd msi 970 gaming am3 mobo
  1. Anyhoo, I got her figured out. Apparently there wasn't a drive letter assigned to the hard drive so I had to assign and designate one for it so the computer knew how to list it in My Computer, so here's what I did.
    Left click start button, right click on my computer, left click on manage, double click on storage, double click on Disk Management, right click on my 2 TB hard drive, left click on change Drive letter and paths & told it to assign the following Drive letter to the drive, which in this case is the letter G: and click OK.

    Problem solved, now all 4 hard drives show up in my computer and work as they should :) ...
    Reply to gsbuickman
Ask a new question Answer