All USB ports not working on 2 different motherboards (cannot even enter BIOS)

Hey guys,

I recently built my first PC, and am experiencing some problems.

My first MB, an Asus Prime B250M-A, was working fine until at some point it stopped recognizing all USB devices. Booting it results in an American Megatrends screen saying NO Keyboard Detected. This went on and on until I RMA'd it and received an Asus Z270-P as a replacement.

The new board was also working fine for about a day or so, until the USB ports cut out again. I reset the CMOS (even by taking the battery out of the mobo), fiddled with the power supply by turning it on and off and it worked again. An hour later USB stops working again and I cannot get it to work. Have already reset the CMOS again and tried USB2.0 ports, USB3.0, hubs, connecting a keyboard directly to back panel usb2.0, connecting another keyboard etc. etc.

It seems as if no power is being provided to any USB ports (even those on the front panel, connected to the MOBO using the USB3.0 header cable). I have a USB bluetooth adapter in the back of the mobo's usb3.0 ports that usually lights up blue when the PC is turned off but the power supply is still on. This is not lighting up now.

I have tried to eliminate all possible variables, running the system barebones without graphics card/storage devices connected, etc. but cannot get it to work again. Since this happened with my previous motherboard as well, I must be doing something wrong, right?

Some more info on my hardware:

Case: NZXT S340
Current mobo: Asus Prime Z270-P
CPU: Intel i5-7500 Kaby Lake
RAM: 2x8GB Crucial DDR4 2133MHz
SSD: Samsung 960 EVO 250GB

If anyone could enlighten me as to what exactly I am doing wrong, that would be a great help!

Edit: Tried another USB keyboard which also didn't work.
Reply to wesselkeijer
No answers Last reply
More about usb ports working motherboards enter bios
Ask a new question Answer

Read More

BIOS Mice USB Motherboards Keyboards