ASRock Z270 Wont Post

Im helping a friend build a PC and the Motherboard wont post. When I switch the power supply on the Motherboard lights go to light blue and then after a few seconds they start to flash red. Pushing the power button does nothing.

We have stripped it down to just one stick of RAM, the power supply, and the CPU with the same results. We also tried moving the RAM to different DIMMs and using different sticks of RAM as the single piece. We also triple checked to make sure all the cables were fully secure. I looked online to find a few others with the same problem and none of those solutions worked either, including clearing the CMOS. Was hoping someone else might have a better idea before we have to start an RMA.

Parts are as follows:
Motherboard: ASRock Killer SLI/AC LGA 1151
CPU: Intel Core i5-7600K Kaby Lake Quad-Core 3.8 GHz LGA 1151
RAM: G.SKILL Ripjaws V Series DDR4 2400 (PC4 19200) (8GB x 2)
PSU: EVGA SuperNOVA 750W
Reply to CdrCain
No answers Last reply
More about asrock z270 wont post
Ask a new question Answer

Read More

Power Supplies CPUs Motherboards