No Display On Monitor - I've checked everything

I've been trying to get my desktop running for about a month now. At first, I had successfully turned it on and went through bios and everything. I installed a new driver on my graphics card and did a restart. After that, my PC wouldn't post anything in my monitor. Moreover, I was almost certain the problem was caused by the graphics card driver update. So, I removed the graphics card, did a reset on the CMOS battery and plugged the HDMI cable to the onboard graphics. The problem persisted. Thinking that the motherboard didn't support HDMI on first boot, I also used a DVI to VGA cable and still had no signal. Therefore, this made me believe the problem had to do with the motherboard. I got another motherboard, different model from Asus and still no signal... I'm losing my head here. Everything turns on normally, all fans are spinning. I've checked everything including the ram and the power cables.

My specs are:
Asus Prime z270 - motherboard
Intel core i5 7600k - processor
Corsair Vengeance LED 2400hz 16gb - memory
Gtx 1060 6gb founders edition - graphics card
Seasonic Gseries 80 plus gold 750w - PSU
Reply to joser23
2 answers Last reply
More about display monitor checked
  1. In the monitor, what input is selected? Set it to hdmi or vga depending on what you are using.
    Reply to Andy Chow
  2. Andy Chow said:
    In the monitor, what input is selected? Set it to hdmi or vga depending on what you are using.


    I set the HDMI input when using the HDMI and VGA when using VGA. Still no signal, I don't think that's the problem since I also tested it in another monitor. Thanks for replying tho
    Reply to joser23
Ask a new question Answer

Read More

Desktops Graphics Cards Monitors Displays