Motherboard does not POST, beeps without RAM, but silent with RAM, no boot

Hi... I am having a strange experience with some old hardware. I have an old ECS H77H2-M3 running a Core i7 3770 and 2 sticks of 4MB HyperX RAM, 1 TB Seagate 7200 HDD, a GTX 650 Ti and a 500W Aerocool PSU. The setup has been running well over 5 years but a recent move had it acting up. It started having BSOD problems and I decided to reformat. The reformat was successful and worked well for a couple of days but started BSODing again. The BSODs indicated issues with the HDD. So I took the HDD to another computer and ran Seagate tests on it which it passed several times. So I reformatted using that other computer and reinstalled windows 10 and it worked fine for another couple of days until its started BSODing again and after one final BSOD, the lights went out.

I took it apart, and tried to isolate the problem. it powers on, the fans spin, but no display through video card nor motherboard DVI/VGA/HDMI. I get no beeps after powering up. and I get beeps when I power it without RAM.

So I bought a used motherboard, this time a Wibtek B75-M. We tested it from the shop and it worked fine. When I got home, I proceeded to move all the components to it except the hard drive and tried to boot it and managed to get it to boot until it asked for the boot device.

Thinking everything was okay, I proceeded to install everything back into the case and install the hard drive with windows 10. Once I started it up, it attempts to boot to Windows but before it completes it, I get a BSOD NO BOOT DEVICE error. it restarts and the lights are out.

Now, the previously working board is behaving exactly the same way as the ECS!

I can't help feeling that it was the HDD that fried it. Is it possible for a faulty hard drive to fry a motherboard? Is there a way I can display post information from this situation?

Thanks.
Reply to gareth820
2 answers Last reply
More about motherboard post beeps ram silent ram boot
  1. Not, a hard-drive cannot fry hardware. It is possible for a bad PSU to fry hardware, and Aerocool is junk.

    Remove the graphic card and try it directly with the screen connected on the board, see if you can enter the bios.
    Reply to Andy Chow
  2. I have tried that several times... nothing.
    Reply to gareth820
Ask a new question Answer

Read More

Hardware RAM Boot Hard Drives Motherboards