Can't pass UEFI BIOS Utility screen no matter what I try.

Hey all,

I recently installed a new seagate hard drive on my PC. Now whenever I boot the PC it boots to the BIOS screen. I have tried uninstalling the hard drive, and that hasn't worked. I built this computer a few months back, and it's worked like a dream until now. I've also tried shuffling around the boot priorities, and that hasn't worked either. I'm lost as to what to try next. I am running Windows 10 Home. I have tried booting from the disk and it just tells me to restart the PC and pick options from a Windows boot screen that never shows up. I would greatly appreciate a helping hand!
Reply to alec1429
3 answers Last reply
More about pass uefi bios utility screen matter
  1. From the BIOS, selecting the drive, you should see the drive twice, once regular, once with UEFI boot. Try the UEFI boot, then, from windows, reformat the new drive as GPT. This should fix the problem.
    Reply to Andy Chow
  2. Actually, I ended up unplugging my main ssd in the process of installing the new hdd, and I realized it when the SSD wasn't showing up on the boot priorities. Thanks though! Crisis resolved!
    Reply to alec1429
  3. alec1429 said:
    Actually, I ended up unplugging my main ssd in the process of installing the new hdd, and I realized it when the SSD wasn't showing up on the boot priorities. Thanks though! Crisis resolved!


    can I ask what model SSD you have and motherboard? I keep seeing this and want to know if its common with a certain brand.
    Reply to Faike
Ask a new question Answer