Need help with drivers and utilities on ASRock Z97 Extreme6

What is up:
I've done a lot of clicking around, reading and watching of videos to try to find out how I need to go about setting this new motherboard up, but I can't get it for the life of me. I am trying to find the source of this bad lag I am having, hoping that this old motherboard is the issue.


My Issue:
I used to have an MSI Z97S mobo and a fully working rig, but my computer has been giving me an issue where I will be using my computer (mainly gaming) and randomly I will lose a lot of FPS and just begin to lag, essentially. In different games I play, it does different things. I play PlayerUnknown's Battlegrounds and on that game, all of a sudden everything will freeze for about 10-20 seconds, then it will say "Network Lag Detected" for about a second or two, then be fine (until it happens again, maybe a few minutes to a half hour later, never knowing when it could happen again) and in Counter Strike: Global Offensive and Subnautica, I get a similar issue where my frames per second will drop from 200 on CS:GO down to about 10-20 for a similar time period as PUBG. Now I thought that this was an issue with something in my motherboard causing a freeze in my connection, then I started playing Subnautica, which is a single player only game, and I would get these similar FPS drops in that game. So I now know it has nothing to do with my internet.


What I have done SO FAR in attempt to fix this:
Purchased a brand new 15 foot CAT6E ethernet cord for my hard wired connection
Replaced my router and modem
Purchased a new GPU
Purchased a new motherboard (ASRock Z97 EXTREME6)


The issue I am having with my motherboard:
I have mounted the motherboard inside the case, I have the drivers and utilities on an 8GB USB drive ready to be installed, and I have purchased a DVD RW internal drive just so I can use the install disc that came with the motherboard. When I try to start up my computer, I have windows installed on my SSD so that is the first boot option, but it gives me a screen saying one of a few different things:


1. A disk read error occurred
Press Ctrl+Alt+Del to restart


2. Driver Disk Preparer v1.08 - ASRock Incorporation, all rights reserved

Model Name: Z97 Extreme6

This model is not supported!

Reboot system now Press any key to continue


3. or finally, it WILL START UP WINDOWS, but none of my devices will work (including my mouse and keyboard that work in the startup of the PC, including LEDs, and during the boot menu, etc)


Please if anyone is able to help I BEG you please give me any knowledge you may or may not have, any suggestions, anything. Normally I am pretty good at figuring stuff out, so even if you can get me pointed in the right direction that would be a tremendous help!

Thank you and MUCH love the the nerd community!! If you read all this thank you for taking the time!!
Reply to humorisog
4 answers Last reply
More about drivers utilities asrock z97 extreme6
  1. This could be many things but I would test your ram first. https://www.memtest86.com/download.htm you can use the free version if you so choose.

    The list of Known issues your are describing are: Improperly configured partition table,
    2 Faulty hard drive
    3 IDE cables failing
    4 Bad RAM
    5 Incorrect or invalid MBR (Master Boot Record)configuration
    6 Issues with bios version
    Reply to DarkEngine
  2. DarkEngine said:
    This could be many things but I would test your ram first. https://www.memtest86.com/download.htm you can use the free version if you so choose.

    The list of Known issues your are describing are: Improperly configured partition table,
    2 Faulty hard drive
    3 IDE cables failing
    4 Bad RAM
    5 Incorrect or invalid MBR (Master Boot Record)configuration
    6 Issues with bios version




    ok, so i dont know much about any of this, how would i go about figuring out if its one of those other 5 issues?
    Reply to humorisog
  3. First things first Is your ram okay?
    Reply to DarkEngine
  4. DarkEngine said:
    First things first Is your ram okay?



    I figured it out, thank you for the help. I decided to open my games up one at a time, and check my CPU usage and whenever I opened basically anything that takes more from your PC than looking at a picture would, my CPU usage would go to 100% and stuff would freeze, as usual. i guess this just gives me a reason to upgrade to a 4790k, haha.
    Reply to humorisog
Ask a new question Answer

Read More

Motherboards CPUs Systems Components SSD Windows 7 Graphics Cards