Solved

Asus mobo help

Hi all
I have just built a computer, not my first, with the Asus maximus formula 9 mobo. All seems to have come together well, but when I boot, I get the ROG screen telling me to press delete or f2 to enter bios and it doesn't matter how many times I press or hold these buttons it won't go to Bios.

I then get the American Megatrends screen, which recognises ram (albeit at a lower speed than the ram I've installed) and CPU and data devices, but it sticks on this screen. The AM screen says press F1 to run set up, but this does nothing also.

My mobo q LEDs are all extinguished except for boot, which is green. The error code display reads A0 which I understand means everything is fine.

I wonder if there is a keyboard issue. All lights display on the kb, indicating there is power. The system speaker doesn't beep to say there is no kb, and the AM screen recognises there is a keyboard but I read in the mobo manual that I should be able to press ctrl alt del to reset and I cannot. Plus I can't seem to get into the bios despite the mobo thinking all is fine.

Grateful for help please!
Reply to mikekay2303
3 answers Last reply Best Answer
More about asus mobo
  1. Best answer
    Same problem as yours, keyboard lights up, not able to press keys. Replacing with a different USB keyboard solved the problem:
    http://www.tomshardware.com/answers/id-3309816/asus-bios-maximus-hero.html

    You may also try using other USB ports first.

    Another similar situation: https://rog.asus.com/forum/showthread.php?90935-Formula-No-USB-Ports-Working
    Reply to raisonjohn
  2. Thanks. Have just tried a Microsoft wireless keyboard. Would that be pointless? Seems to be connected to its hub before I need to press del. Didn't help.

    Have tried almost all the usb slots, front and back.
    Reply to mikekay2303
  3. I needed to use a different keyboard. Logitech G510 didn't work,cheap big w keyboard did.

    Now if I could just work out how to get Windows installation to recognise my m.2 Samsung 960,ill be underway...

    Thanks for your suggestion.
    Reply to mikekay2303
Ask a new question Answer