Cannot get my bios to update

I recently purchased a ASRock Fatality AB350m Gaming K4, and I am trying to get the bios to update. I went to the ASRock website, and followed their procedure on how to download the "instant flash" option. I downloaded it onto a USB drive, and when I rebooted into the Bios it brought up an error saying "cannot locate image file." I tried a different USB, making sure it was formatted to FAT32, and even tried 2 different USB ports on my computer setup.
Thank you everyone ahead of time, I really appreciate it.
Reply to folorndarkblade7452
2 answers Last reply
More about bios update
  1. You usually have to navigate to the USB - and naming conventions are not obvious.

    Are you sure you're selecting the USB drive to search for the BIOS file?
    Reply to Barty1884
  2. I was able to figure my issue out. When I downloaded the update onto the USB drive I was using it automatically placed it within a folder. I guess it was not able to read the file with it being inside the folder, because when I put the file on the USB without it being in a folder it was able to find the file and complete the update.

    Thank you for your help.
    Reply to folorndarkblade7452
Ask a new question Answer

Read More

BIOS ASrock Motherboards