window 10 freeze and shutdown when I install an wifi card on PCI Express 2.0 x1 Slots

Hi all,
I really want to heard some suggestions for my problem .
First of all, here is my computer information :
- Rygen 7 1800x
- MB : ASRock Fatal1ty X370 Professional Gaming
- 32Gb RAM 3000
- 2 M2 SSD
- 2 1080Ti cards
My problem is when I install an external wifi card on PCI Express 2.0 x1 Slots ( the Motherboard itself has intel wifi card ) , my pc freeze at start up and it automatically shutdown . When I remove the external wifi card, everything seems fine .
My external wifi card is Asus PCE-AC88 .
I dont know where the problem is, please anyone have some suggestions for me ?
Reply to herophongtran
9 answers Last reply
More about window freeze shutdown install wifi card pci express slots
  1. It likely has something to do with the already included Wireless LAN.
    Intel 802.11ac WiFi Module (Free Bundle)

    Are you trying to use two Wireless LAN devices?
    Reply to Calvin7
  2. Calvin7 said:
    It likely has something to do with the already included Wireless LAN.
    Intel 802.11ac WiFi Module (Free Bundle)

    Are you trying to use two Wireless LAN devices?


    I prefer the ASUS rather than the one come with the Mb :(
    Reply to herophongtran
  3. see if you disable internal wireless that system work with your card also try her in the lower pci x1 slot and not the 2.0
    Reply to scout_03
  4. scout_03 said:
    see if you disable internal wireless that system work with your card also try her in the lower pci x1 slot and not the 2.0

    Thanks for your help but I tried and nothing change
    Note that, when I restart the window, it will freeze on the login screen and shutdown if the pcie wifi card is installed , BUT if I remove it and restart , window works normal , and when I login to the window, and install the pcie wifi card , window is not freeze but it will not know there is the new hardware installed :( strange
    Reply to herophongtran
  5. have this wi-fi card test in another system to see if same boot issue happens .
    Reply to scout_03
  6. scout_03 said:
    have this wi-fi card test in another system to see if same boot issue happens .


    I have just figured out this : before my RAM are OC at bus 3000, when I let them run at the default bus 2133, the system work well with the wifi card :)
    Does it has anything related to the voltage or somethings else ? Can someone explain to me and how can I push my RAM run at 3000 and dont effect the wifi card ?
    Reply to herophongtran
  7. dont touch voltages try to set up xmp only for the ram in uefi .
    Reply to scout_03
  8. scout_03 said:
    dont touch voltages try to set up xmp only for the ram in uefi .


    I just select the 2.0 XMP profile and let the RAM run at 3000, did not modify anything related to voltage :( of cause when I set the RAM to 3000, the voltage for them also set to 1.35V automatically
    Reply to herophongtran
  9. did you try axmp 1 to see if it does the same .
    Reply to scout_03
Ask a new question Answer

Read More

WiFi Shutdown PCI Express