B350 carbon pro doesnt post after bios update

Hello everyone, i realized a bios update through m-flash, as usual, after (i think) it was done the screen was black, resenting wont help. Searched and tried msi's recovery method with no luck, also tried cmos reset, but cant get it done(after i do it screen is all black and doesnt says anything about the reset as ive read it should), unplugged battery and re tried de cmos, no luck. Ez debug led cpu and dram flashes at the same time, for about 2 seconds and the go off, mouse and keyboard doesnt seem to get power when plugged in .
I realized there was a new bios update, since ive been having troubles with memory stability i decided to update with no luck. The computer was working fine before the update. The specs are:
CPU: Ryzen 7 1700 at stock speed
RAM: its a 2400Mhz module mushkin or something like that (on my way to the university and forgot to check). Actually running at 2100 as i was having issues with stability.
Mobo: b350 carbon pro
GPU: msi oc gtx1060 6gb
HHD: 2 hhds 1tb

Thanks for reading, im lossing all hope here, system is 15 days old :'(. Sorry for the bad english.
Reply to leouan_1905
No answers Last reply
More about b350 carbon pro doesnt post bios update
Ask a new question Answer

Read More

RAM Flash CPUs BIOS Motherboards Memory