asus z170 pro gaming aura wont boot up unless i change sata ports

like the title says. I get a black screen with a nonblinking underscore on the top left corner of the screen when i turn on the system but if i plug the sata cable of my secondary hdd into a different port of all 6, the system boots up windows 10 normally. I tried updating the bios, reinstalling windows, uninstalling the sata drivers and set the disk storage to AHCI but still get the same black screen. The only solution i have found is plugging the sata cable into another port and then the system will boot otherwise i get the infinite black screen and no boot cant even get to the bios. I think the problem is the motherboard but im not sure. I dont want to buy another one if i can fix this one. help please!
Reply to mikecb16
3 answers Last reply
More about asus z170 pro gaming aura wont boot change sata ports
  1. Please add which exact sata port causes this as sometimes they are disabled due to another device being installed. Thank you.
    Reply to popatim
  2. All 6 ports give me the same problem. The system wont boot but if i change the sata cable into any of the 6 ports then the system will boot up. But when it boots up if i restart i get the black screen again so i have to do the same process, change the sata cable into another random port of all 6 ports. I also have an m.2 installed, however i dont think this is the problem because i removed it and still got the black screen.
    Reply to mikecb16
  3. Wow, that is strange. TY for clarifying.
    Reply to popatim
Ask a new question Answer

Read More

SATA Boot Motherboards