graphic intensive games shut down randomly on new pc

Hi,

I have ordered my new custom build pc for the first time, and it should really run smoothly anything but when I try to play any high end games mass effect Andromeda, battlefield 4, witcher 3
it just randomly exit the game back to desktop without any error messages and I have no idea anymore whats causing it past 48 hrs I am checking and troubleshooting left and right everything and just cannot find any fix for this problem. Checked tempretarues but nothing seems off the scale stays silent and cool.

I tried reconnecting cables on GPU,PSU, lowering setting as well for only performance, uninstalled drivers than updated back again, and its like that since out of box which is really weird and customer service had no usable advice either.

Here are my specs:
Didn't OC

AMD Ryzen 7 1800X 8 Core (Socket AM4) Processor - Retail
Corsair Vengeance LED Red 16GB (2x8GB) DDR4 PC4-25600 3200MHz Dual Channel Kit
24x DVD Writer
NVIDIA GeForce GTX 1070 8GB GDDR5
Windows 10 for high end devices
Novatech Power Station Black V2 Modular 750 Watt PSU 80+ bronze
Cougar Panzer Max
Asus Prime B350-Plus AMD AM4 B350 Chipset Motherboard
Cooler Master Hyper TX3 EVO CPU Cooler
TP-Link WDN4800 450Mbps PCIe Adapter
Samsung 850 EVO 500GB SSD (up to 540MB/s R | 520MB/s W)
3TB SATA HDD (7200RPM)

Ps.: sometimes when I start it up it shuts down while booting following with a weird sound at the time, maybe power shortage so I suspect it might be the psu being faulty, but it doesn't happen every time. So far the only game running is League of Legends.
Reply to g.borisz18
2 answers Last reply
More about graphic intensive games shut randomly
  1. It's most likely the PSU. Try downloading FurMark and run it with the 1080p preset. I'd suggest that you send back that PSU and get a better brand, something from EVGA or Corsair would be a good choice without having to spend tons of money.
    Reply to CircuitDaemon
  2. CircuitDaemon said:
    It's most likely the PSU. Try downloading FurMark and run it with the 1080p preset. I'd suggest that you send back that PSU and get a better brand, something from EVGA or Corsair would be a good choice without having to spend tons of money.


    yeah I have a feeling its the psu,used furmark reached 100 fps on the run with 6100 score nothing odd happened
    Reply to g.borisz18
Ask a new question Answer

Read More

Video Games Games Shutdown Gaming PCs