Solved

I screwed up during a bios update..Help please.

I tried to flash my gigabyte a320 hd2 motherboard with the f4 bios update and the update was disturbed by a power cut midway and I have a bios failure.My display is not responding to my gpu,usbs are dead and I tried putting in my motherboard disc but it is not responding the screen just stays blank with the no display message.I opened my cabinet and all parts seemed to working all fans where spinning and the lights on the motherboard where on.I was using the flash option from appcenter and the power cut occured during the reboot after flashing was complete.How do I fix this?Thanks for your help guys.
Reply to shubhamdas7
2 answers Last reply Best Answer
More about screwed bios update
  1. Best answer
    there is normally a set of pins next too the bios watch battery which should reset the bios or removing the battery for ten minutes say will reset it worth a try.
    Reply to RARRAF
  2. Also try flash the BIOS again with USB again. Sometime it will work. And if you can't work it out, you have to contact gigabyte to see they will replace the BIOS chipset or MB for you.

    Keep in mind your MB has only one BIOS chipset, if you screwed it up, you have to replace that BIOS chipset. If the MB has dual BIOS chipset, you will have chance to use the backup BIOS chipset.
    Reply to cin19
Ask a new question Answer

Read More

BIOS Gigabyte Motherboards