UEFI doesn't detect my HDD, But BIOS does.

Hello ! I've been trying to solve this problem for about 2 days in a row, so the thing is that one day my laptop which I had installed ubuntu and windows 8.1 freezed, I tried to restart it and after that I couldn't do anything, I tried to boot ubuntu and windows and it gave me this error : "Windows Manager Boot failed" , "ubuntu boot failed". I tried to reinstall windows but the windows installer wouldn't recognize my hdd, so I started to look around for answers.I played around with the boot settings without any succes. The thing is that when the BOOT MODE is set on LEGACY SUPPORT and the BOOT PRIORITY is set to UEFI first, the laptop enters an automatic repair mode, where I can select ADVANCED->CHANGE UEFI FIRMWARE SETTINGS, and there I see that my hdd is not recognized. But when I enter BIOS SETTING by pressing F12 I can see my HDD. Can someone help me with this ?
Reply to jaxandrei
7 answers Last reply
More about uefi detect hdd bios
  1. is your HDD is formatted in GPT?
    Reply to nitinvaid20
  2. Thanks for the reply, nitinvaid20? How can I check if my HDD is formatted in GPT ?
    Reply to jaxandrei
  3. You might need to Enable CSM in your BIOS for it to read the hard drive. Also make sure that Secure Boot is disabled.
    Reply to Neur0nauT
  4. Thanks for replying Neur0nauT, but I can't find any settings in BIOS that will help me to Enable CSM and disable Secure Boot, I have 4 TABS : Information, Configuration, Security and Boot, and no one of this tabs contains any setting that will help me enable csm or disable secure boot.
    Reply to jaxandrei
  5. What is your laptop model?
    Reply to Neur0nauT
  6. Neur0nauT said:
    What is your laptop model?


    laptop lenovo y510p
    Reply to jaxandrei
  7. Disable secure boot should be under the security tab. If it will not allow you to highlight or select the option, then you will have to give the bios an admin password first. Something simple like 1234 etc. afterwards, you should then be able to change this secure boot setting.

    So, disable it, then the USB will be recognised within the boot menu by pressing F12, or Fn+F12) Once you've successfully reinstalled your OS, you can go into the bios and remove the admin password if you want. (advisable)
    Reply to Neur0nauT
Ask a new question Answer

Read More

BIOS Boot Hard Drives uefi