Gigabyte and Xtreme Gamer combination wont work

Hello all,

Sound Card: Creative SoundBlaster X-Fi Xtreme Gamer
MotherBoard: Gigabyte GA-78LMT-USB3
OS: Win 7

The motherboard has three PCI slots:
1. PCIEX16 - this slot is Occupied by Graphics Card and working superb
2. PCIEX1 - this is empty and the sound card cannot fit here.
3. PCI - Sound card is here

The above combination of MOBO, Sound Card and OS does not work and the device manager never recognizes the soundcard. This is a beautiful card and used to work awesome when I had XP.

I have tried every possible method, Googled info but everything gone in vein.

Can anyone suggest how to get this sound card working on my mobo?

Thank you in advance.
Reply to phani_astronomy
4 answers Last reply
More about gigabyte xtreme gamer combination wont work
  1. Have you made sure that onboard sound is off / disabled?
    Reply to mips42
  2. "Have you made sure that onboard sound is off / disabled?"

    Yes! I have uninstalled the Realtek drivers too.. but that did not solve the problem
    Reply to phani_astronomy
  3. Have you tried anything else in the PCI slot?
    Reply to mips42
  4. Try the DanielK driver suite, the official drivers have a lot of issues on Windows 7, and Creative hasn't exactly been keen to keep the X-fi lineup working.
    Reply to gamerk316
Ask a new question Answer

Read More

USB3 Gigabyte GA-78LMT-USB3 device manager never recognizes the soundcard Gigabyte Sound Cards creative SoundBlaster X-Fi Xtreme Gamer PCI Motherboards Creative PCIEX16