Cant power up my motherboard.

Just got done installing my Asus ROG Zenith Extreme X399 with Ryzen 1950x and for some reason i cant power up the computer.

The front power button dosnt work nor does the start button on the motherboard.
When i first started up the power (connected the power cable to the psu and pressed the power switch on the back side) the RGB lights turned on on the motherboard but the little fan that is build in dosnt start nor the fans that is on my case.

I've noticed that one of the pins \ one of the small wire on my 24pin cable isnt there and there isnt any signs that there was a pin \ wire there on both sides on the cable. Dont know if thats the problem.

I also started up the psu with a "kickstarter" tool to see if there was any problem with the psu but everything that was connected got power.

The cpu is correctly installed. Followed the steps in the manual just to get it right but waaaiiit atleast it didnt blow up..

It might be my psu dosnt support the components but it worked fine with the old components i had (MSI Gaming 5, I7-4790k) and i dont see why the psu dont work with the new components.


I dont know why it shouldnt work nor why i have problems.. Thats why i ask.


My specs:
Asus ROG Zenith Extreme X399
Ryzen Threadripper 1950x
Evga Supernova 850 g2 850w
Evga Geforce GTX Titan X
Corsair Vengence RGB 16gb 3000MHz
Reply to insty
1 answer Last reply
More about power motherboard
  1. Did something. I dont know what but it works now. Dont know how to delete this post thoo
    Reply to insty
Ask a new question Answer

Read More

Power Supplies Power Up Motherboards Power