Solved

Ryzen 5 / GA-AB350 won't post

Hi everyone.
I have a Ryzen 5 build that won't post. Basically when I then the PC in all the fans and LED'S work just fine but the CPU led on the motherboard is on (meaning the CPU is unhappy). I replaced both the motherboard and CPU but the exact same issue is occurring making me think it is either an issue with my power supply or ram. However, since my ram is on the supported list of the mobo manufacturer and the ram led isn't on, the only problem I can think of is the PSU, but it had worked just fine with a previous build which should have had a higher power consumption. Any ideas? Thanks.
Reply to thetetanusclam
4 answers Last reply Best Answer
More about ryzen ab350 post
  1. can you post detailed specifications of your build?
    Reply to Gaurav_40
  2. Gaurav_40 said:
    can you post detailed specifications of your build?


    Yeah. Ryzen 5 1600 / ASUS GTX 960 / gigabyte AB350 mobo / 8 GB (2x 4GB) ddr4 2666 ram (on supported list) / CX430 (430 W PSU)
    Reply to thetetanusclam
  3. Best answer
    Check the power leads to the motherboard are fully home, ( one 8 pin one 24 pin ). That big 24 pin plug can be extremely hard to push in fully, try removing it, lubricating it with a little petroleum jelly and reinserting it.
    If that fails, try another known good power supply.
    Reply to coozie7
  4. I take it that worked?
    Reply to coozie7
Ask a new question Answer

Read More

Power Supplies RAM CPUs LED Monitor Build Motherboards