Asus Z170 Pro won't boot

I just installed a new Z170 mobo to my PC and I cannot get it to boot. Below is a list of my PC's specs for reference.
-Asus Z170 Pro MOBO
-i3-6100 CPU
-XFX RX 480 8gb GPU
-Corsair 500w PSU
-(2x8gb) Crucial 2133mhz RAM

Here's a list of things I've tried so far:

1. Reset CMOS by removing the battery from the mobo
2. Remove GPU and hook monitors directly into mobo
3. Ensure that all necessary cables are firmly connected
4. Swap DIMM slots for RAM and try booting with only 1 stick

Oddly enough, after I removed the GPU, I was able to get my PC to post but not boot by unplugging the case fan power cable from the mobo. Could this somehow be the issue? Any help provided is greatly appreciated.
Reply to elarsen
6 answers Last reply
More about asus z170 pro boot
  1. Try to get beeper and boot without RAM- wait for beeps (to be sure if bios is OK).
    Reply to romirez
  2. Forgive me for my ignorance, but what do you mean by beeper? Is that a piece of software, or a literal beeping device, or what?
    Reply to elarsen
  3. Beeper or *PC Speaker*
    Reply to romirez
  4. Ok thank you for the clarification. I ordered one from an online distributor and it should arrive Monday. I'll post results then.
    Reply to elarsen
  5. In the meantime of waiting for my speaker to arrive, I tried reinstalling my old mobo, a Gigabyte H-110m-a, and my PC will not boot with it installed either. Upon pressing the power button, the fans will briefly lurch and then stop completely. Also, the case LED and the LEDs on my fans blink and then go off. Could my PSU be bad?
    Reply to elarsen
  6. PSU or CPU or pins in both sockets.
    Reply to romirez
Ask a new question Answer

Read More

Asus GPUs Boot