Do you know ASRock beep codes? System is breadboarded. What is next step with beep codes from AMI bios on ASRock board?

System has been breadboarded. I have tried everything at the amateur level. It's down to the motherboard or CPU.

Here is what is connected:

ASRock Z97 Anniversary motherboard LGA 1150
Intel i5-4590
Cooler Master EVO 212 HSF
EVGA GQ850 GPU

The power supply is not an issue. All fans are plugged in now, but I ran my tests without them attached and came out with same results. I have not yet taken out the CPU to try to power only the board. And I had a very good install originally with the processor and HSF, I really don't want to mess with it, it's been solid since Day 1 for a year and a half. No bent pins.

Here's my progress so far:

1. Board is totally dead. Power supply is good. The PSU is currently turned off, and is plugged in to a UPS/Line Conditioner that is plugged into the wall. The main cable is attached securely to the ATX socket via a 20+4 plug, and for the CPU socket a 4+4 plug. I have eliminated the case switch and any other connectors from the case. The HSF and 2 chassis fans are plugged in to the board, just to help me tell more easily when the system comes on.

2. And now I try to turn on the system power with a screwdriver jump. There are no indicator lights on the board at all, only one small light over the RJ-45 port on the backside of the panel with all the other ports. It is not on. At this point, I don't know where the power is stopped. Trying to turn on the board with the screwdriver jump does nothing. That light is my only indicator, and it is not on right now, yet the PSU is on at it's switch.

3. So I remove the brand new CMOS battery and leave it out for a few minutes. There is a CLR CMOS jumper on the board, but I'm not sure what this would do vs. just taking the battery out. The board's manual is no help.

4. Now I put the CMOS battery back in. Turn on PSU. The little light over the RJ-45 jack is lit. So now I know power is getting to the board past the point that stopped it during the previous shutdown.

5. So I jump the power pin. Board comes on, all 3 fans spin up, and the light accents are working. Right this second, it sounds fine with what is connected.

6. That "on" state lasts for a full 8 seconds exactly. Right at the end of this phase, the speaker emits one long beep, then the computer completely shuts down. But power light still shows steady at the RJ-45 jack. Now I count off exactly 4 seconds, and the cycle starts. It powers up on its own for 8 seconds, during the end of which, the speaker emits a long beep lasting 1 second. Then shuts down for exactly 4 seconds, then restarts, run for 8 seconds, beep, shut down, off 4 seconds, restart, beep, shut down, restart, beep, shutdown, restart, etc.

7. I turn off the power at the PSU switch. But now if I try to turn the machine on again, there is no power, I am back to being completely dead. So I have to take the CMOS battery out again. I ran this test several times with slight variations, but got same overall start-beep-shutdown-restart-beep-shutdown pattern.

So, now I'm at the point I have been able to establish a pattern. I don't definitively know what the version of BIOS is going to represent in beep code communication, but there is one iteration of the AMI UEFI Legal BIOS that says "DRAM PROBLEM". So I have decided to proceed to the next step and add a part to the mix.

8. I add one stick of 4mb RAM to the motherboard. I still have to do the CMOS battery reset to get power to the board. I also hooked up the case switch, just to be easier than the tip of the screwdriver thing.

9. As before, the system has the PSU switch on, and the light above the RJ-45 port is lit. I turn on the system, and again, the fans spin up and the lights are on. And again, after 8 seconds, the system shuts down. Completely. But this time no beep at all, just fans running for 8 seconds, then completely off. And the green light over the RJ is out now too. To reset the board with power to be able to be turned on, I have to do the CMOS battery removal again. I try the test again, with just one stick of RAM, but a different stick. And yet another. Changing slots. All same exact result. Powers up, runs 8 seconds exactly, no beeps, shuts down completely, even though PSU switch is on, there is no power to the board at all.

At this point, I do not know what to do next. There was one section in the ASRock FAQs about the beep codes, but some had to do with "no beep" and did not interpret what was wrong. One long beep is supposed to be a memory issue, but I don't understand what is wrong from running 8 seconds, no beeps, then complete shutdown. I have started an RMA on this board, but who knows how long that will take?

Any help greatly appreciated.

Erik
Reply to erikbrown
10 answers Last reply
More about motherboard expert system breadboarded step beep codes ami bios asrock board
  1. You write about DRAM problem, but never identify by part number any memory used.
    Reply to Calvin7
  2. well if you like just try booting to the bios via hammering the delete button leave it at the bios screen for say 30mins just to check it is stable.
    Reply to RARRAF
  3. Calvin7 said:
    You write about DRAM problem, but never identify by part number any memory used.


    Yes, I do address the DRAM problem indicated by the AMI Bios Beep Code Identifier table I found here. And the ASRock one should be the one to use, but it's different. MSI uses AMI UEFI BIOS as well, and their beep codes are different too. I don't think the memory is the problem.

    The main memory I have tested that have been used with this board is:
    Crucial Ballistix Sport 2x4GB 1600mhz PC3 - same memory I bought with the board in 2016.

    Also tested with a single Elpida stick 1x4GB 1600mhz PC3. These memory sticks were swapped in and out one at a time, different slots, different combinations. All same result. Turn on, no beeps runs 8 seconds, shuts off. But will turn back on with the screwdriver jump. You can do this one time, then the board has no power after second shut down, but the RJ light is lit. But screwdriver jump fails. But I don't have to take battery out now as I did with no RAM, I can reset by turning off the PSU for a minute.

    Thanks for the reply hope the extra information helps somehow.

    :??:
    Reply to erikbrown
  4. RARRAF said:
    well if you like just try booting to the bios via hammering the delete button leave it at the bios screen for say 30mins just to check it is stable.


    Believe me, I would be ecstatic if I could get to a BIOS screen, I would be at home there. I have not had a keyboard plugged in the entire time during breadboard testing, as I have no screen output either. I ran all my tests without screen connected and with screen connected. During the two types of boot, there was never even any flicker to the screen.

    But I'll try the keyboard. What the hell? Thanks, I'll let you know.
    Reply to erikbrown
  5. No luck trying the keyboard while computer is on for the 8 seconds, no output to screen whatsoever.
    Reply to erikbrown
  6. the Cooler Master EVO 212 HSF is fitted correctly and screwed up nice and tight to the back plate ??
    Reply to RARRAF
  7. RARRAF said:
    the Cooler Master EVO 212 HSF is fitted correctly and screwed up nice and tight to the back plate ??


    Yes. Perfect fit and installation.
    Reply to erikbrown
  8. The BIOS beep is positive indication that everything: motherboard, CPU and RAM are working an so is the BIOS but it may have an issue that may be corrected with a BIOS Reset... or a BIOS Recovery if the reset doesn't help. The "dram problem" may be real, but may not and related to the BIOS issue.. it's not working properly so it may be detecting a false dram issue.. so do as follows:

    1. First try resetting the BIOS you said you already did this but said you removed the battery for a "few minutes"... If you didn't allow at least 5 minutes you need to do a reset again... I know of several ways to reset the BIOS and one even takes overnight, so a few minutes may not have been enough.

    To reset the BIOS correctly:
    a) Remove the AC power cord or turn the PSU switch off,
    b) next remove the battery,
    c) move the BIOS jumper from pins 1 and 2 to 2 and 3,
    d) next press the front panel power switch and hold it pressed for a minute, and wait 10 minutes before reverting everything and turning the PC on.

    2. If that doesn't help, do a BIOS recovery: See if the motherboard manual has instructions for Recovering the BIOS, a factory adviced BIOS recovery method would be recommended and if you can't find one, this method should apply to any BIOS: Do as with the BIOS reset, but with the only difference being that the BIOS jumper should be removed and left off the 10 minutes.

    3. See if cleaning the RAM slots (or dram slots) with a soft cotton cloth, wrapped around a small paper clip, and moistened with a few drops of alcohol. Run the cloth along the RAM slots, and if the cloth comes out with a stain, do a second pass and repeat if necessary till it comes out clean. Wait a few minutes for the alcohol to evaporate before reinstalling the RAM modules and trying the computer. If it doesn't help try #4 ↓

    4. Try one ram stick at a time on all slots and making sure it seats properly on the slot, and the ram locks should click one after the other. You should press with fingers on both the RAM stick ends, pressing slightly harder on one side, so one side clicks first then the next.
    If that doesn't help, or at least remove "dram problem" from the board display, you'll have to try a different RAM module.

    http://www.bioscentral.com/beepcodes/amibeep.htm
    1 short DRAM refresh failure
    1 long POST has passed all tests
    Reply to Chicano
  9. 1 short DRAM refresh failure
    1 long POST has passed all tests

    Sorry I am just getting back to this a couple weeks later. Thank you very much for the detailed post, Chicano. I will try these things, even though I have tried most of it already, especially with the different RAM modules in different slots. The main things I will try are the complete BIOS reset you describe using also the CMOS jumper and I will also do the cleaning.

    I do not understand how the CMOS reset with the jumper pins will do anything when the power button is pressed if the battery is out and PSU is unplugged. Did you type that sequence correctly? Am I supposed to plug the PSU back in before holding the power button on?

    I had the board ready to go back RMA, but I will try this one last time. This will give me one more chance to re-build the system from scratch and re-check everything fresh after a few weeks of not looking at it.

    Another question: where can I get a CPU socket cover if I have to ship the board? It came with a pretty nifty one since it was the Anniversary Z97 edition, but I don't know what I did with it.

    Thanks again, will report back soon.
    Reply to erikbrown
  10. Yes the sequence is correct; Pressing the power button after removing all power sources, unloads charge retained in capacitors... and can work when not unloading caps doesn't. And don't forget the BIOS recovery... I have more faith on it than on the reset.

    Removing the PSU connectors would do the same as removing the AC cable or turning the PSU switch off. The PSU has it's own capacitors so better leave it unplugged when pressing the power button.


    You can probably buy the socket cover anywhere computer parts are sold.. but here's one option:
    https://www.outletpc.com/px7788-cpu-cover-for-1156-115x.html

    And lots more.
    https://www.google.com/search?rlz=1C1AVFC_enMX753MX753&q=intel+socket+1151+covers&spell=1&sa=X&ved=0ahUKEwj_pZWRj-LWAhWIjFQKHeEmDlAQBQglKAA&biw=1523&bih=718&dpr=1.25
    Reply to Chicano
Ask a new question Answer

Read More

BIOS Boot Failure CPUs Motherboards Hardware Problem