ASRock Fatal1ty K6 doesn't detect ANY boot device

Hi there,

So here's my problem. I've got an ASRock Fatal1ty Z270 K6 mobo, it's one week old. I am using an SSD as a boot device, and I've got an HDD for storage. Everything worked perfectly fine until yesterday. Playing around with ASUS GPU Tweak and ASUS Aura to change my LED colors, I noticed upon restarting my system that boot was considerably slower than before, as in no SSD involved any more.

Getting into BIOS confirmed that priority had been changed, I just couldn't use my SSD anymore although it was in the boot list. Had some issues as well with my mouse being laggy in BIOS. So I went for an update on my BIOS, and then it all started. I managed to fix the mouse issue, but then trying to change boot options again the SSd and HDD just disappeared in my face.

The problem now is not only did my SSD disappeared from boot list, but my HDD too. I just can't get past BIOS because boot list is empty. So it's an endless loop of not getting much far.

Tried to power off whole system and wait, nothing.
Windows installed on SSD.
BIOS does recognize both drives as storage devices, but none as boot devices.
BIOS up to date.
In fact, I am not quite sure if the BIOS update is not responsible for the drives disappearing, because I think both were detected before the update.


Any help here would be appreciated !
Reply to Gamrod
1 answer Last reply
More about asrock fatal1ty detect boot device
  1. So I finally managed to get into Windows. I cleared CMOS, then SSD was detected as a boot device. Altough I got a BSOD saying INACCESSIBLE_BOOT_DEVICE, then a loop started ; computer rebooted, got BSOD again but that time I was offered to reinstall Windows. I did that and now I can get into Windows.
    Reply to Gamrod
Ask a new question Answer

Read More

SSD Boot Hard Drives ASrock