Another A2 post error

I've looked through the available search results for this error, but was not able to find much that explained my problem, nor solved it.
Inexplicably, my MSI Z87 Mpower Max stopped booting after a move to a new house. Kept getting to a Q code of A2 and stopping there. Not able to get in to BIOS or do anything . After much searching and trying out a multitude of attempts to fix, I gave up having been led to believe that the issue was either the mobo or cpu. So, I went out and bought new guts, an ASUS x299 Deluxe along with an Intel i7 7740x, and topped it off with 32 GB of new Crucial DDR4 ram. I loaded this all up in the old case along with old PCU and boot SSD and a multitude of other HDs I've got hanging off this mobo.
Guess what , cannot boot into BIOS. Stops at A2 error still. WTF!! right?
So, I went bare bones and took the mobo out of the case, took all boards (GPU + WinTv card) off, disconnected all drives, kept just 1 stick of ram along with the installed Kraken 62 water cooler. Even bypassed the 850 watt Corsair PCU to a 450 watt "spare" I had. Nothing else on this board........nothing, not even any of the front panel connectors. The board was out of the case, sitting on my desk for Gods sake. Still getting the A2 code and CPU or BIOS hangs there! A completely different board/CPU/RAM/PCU .....and still same Q code.

Someone please explain to me what on earth is going on here and how do I remedy it. Surely it cannot be yet another defective piece of hardware. Hard to believe. But, it has to be something.

I'm very disappointed and upset over my inability to, yet again, solve my problem here.
Here's hoping someone much brighter than me (not too hard to accomplish) is able to provide a solution to this issue. My only other potential next step is to request Amazon to accept return/replacement of the ASUS x299. Maybe.

Thanks in advance
Devildoc
Reply to rtomas99
11 answers Last reply
More about post error
  1. Try testing different monitor and/or video cable. A2 indicates missing booting device, but there should be signal on monitor.Video issue, I'd say. Graphics card, monitor, or cable.
    Reply to alexoiu
  2. alexoiu said:
    Try testing different monitor and/or video cable. A2 indicates missing booting device, but there should be signal on monitor.Video issue, I'd say. Graphics card, monitor, or cable.


    Actually, yes, I did that. Different monitor as well as graphics card. However, what I was actually attempting to report with my original post, was that I breadboarded the mobo which, as you may well know, is a troubleshooting method of trying to identify the culprit by stripping the system down to the absolute bare minimum required to still achieve start up, or at least get it past the A2 errror spot. So, only a motherboard, 1 stick ram, cpu cooler, and power. No graphics card, no monitor, nothing else. Still the A2 error.
    Or am I wrong. Is the A2, in this instance, happening because it's looking for a device that, at this point, it's not seeing?

    Btw, thanks for your reply.
    Reply to rtomas99
  3. No problem.
    A2 with x299 board, graphics card removed?
    Reply to alexoiu
  4. Yes
    Reply to rtomas99
  5. Weird. What if starting the pc with RAMs removed? What code getting?
    Reply to alexoiu
  6. code 53 : memory error
    Reply to rtomas99
  7. Now, with graphics card removed, install single RAM module, start the board and see if A2 or different code.
    Reply to alexoiu
  8. So, here's where I'm at now. I posted a jpg of the socket on the MB which seems to show several missing pins. ASUS tech guy reports that's a defective board and to return it. Anandtech senior member agrees. So I contacted Amazon and a new board is on the way. I'll let you know if that solves all my mysterious problems or not!

    RT
    Reply to rtomas99
  9. Thank you for the update.
    Reply to alexoiu
  10. alexoiu said:
    Thank you for the update.


    So, indeed, I did send the MB back to Amazon and today received it's replacement. I had hoped my problems would be solved, but, unfortunately not. The previous errors were resolved, now I've two new issues that are unique in my experience. First is that whenever I populate the X299 with 4 sticks of 8GB ram, I get a "memory detection" error and the board will not boot. I kept changing memory configurations until I established that the error occurred whenever the D2 slot was filled. One or two or three sticks of ram would be fine and allow boot to continue. Why the fourth slot is an issue is unknown. I changed out all 4 sticks to verify that they all worked fine. Another MB issue? Really?

    The second issue is that, when in the above example, the boot does continue, it gets to this screen (see attached) and no further. The PC will go no further and shuts off in 15 sec as it states. Cannot get into setup. What issue is this highlighting and what does "USB over current status detected" mean?
    Reply to rtomas99
  11. An issue with some of the USB devices. Are you using a hub?
    Now, regarding RAMs, try loosening a bit the CPU cooler.
    Reply to alexoiu
Ask a new question Answer