Afterglow Xbox 360 controller stopped working

Hello, I have bought an Afterglow Wired Xbox360 Controller about a month ago and plugged it to my PC with Windows 10 64-bit. It was working perfectly, glowing and rumbling, I was playing Dark Souls. Then I went with my family for about 2 weeks, and came home 2 days ago. I downloaded Project64 emulator and Donkey Kong 64 to see how would it work with Afterglow, and worked without problems.
Today's morning I plugged my Afterglow, and it's glowing green by all LEDs, but Guide Button doesn't, and whole controller isn't working, neither with Souls nor Project64. Windows doesn't beep when I plug or unplug it, doesn't see it at joy.cpl, Device and Printers or Device Manager, controller just glows green so he must be powered-up. I tried with USB in front and back of PC, still only glowing. Could you help me?
Reply to zanstaszek9
1 answer Last reply
More about afterglow xbox 360 controller stopped working
  1. Generally those controllers are absolute crap. I would not be surprised if it just gave up.
    Reply to XxD34THxX
Ask a new question Answer

Read More

Controller Xbox 360