Slow pre-windows (bios) boot after RAM OC.

Hey Guys.
I'm posting this thread, my first in fact after i've wandered in the internet for long enough and through many other threads in vain, trying to solve a problem i've faced since i've got myself this new pc.
So here are it's specs :

MOBO : Asrock x370 Killer SLI
CPU : Ryzen 7 1700X
GPU : MSI GTX 1070 Aero OC
RAM : 16go (8x2) Corsair LPX 3200 mhz (cmk16gx4m2b3200c16)
Storage : Samsung 960 Evo 256gb + 1TB WD HDD.
PSU : Gigabyte B-700H
Latest Bios and AM4 chipset drivers installed

*So Previously I've had a problem with another RAM kit, clocked @ 2133mhz (an Adata one) where games would start stuttering when loading new assests (witcher 3, Rocket League, GTA V) and the frame rate dips to like 0 then goes back up, repeatedly for like each 5 mins. Very annoyed i decided the get a new RAM kit.*

After Installing the New RAM and setting the XMP profile and fiddling with RAM clocks, the problem i've had with games was no more (except a bit for Rocket League), and I've found that @ 2933mhz the RAM is pretty much stable and windows can boot normally with it, but the problem is after i've shut the PC down, and after a fresh boot i've noticed that the time for the ASROCK logo to show up, went up by 10 seconds (from 7 to 17), and for two times now, my pc would shut down for no reason : Once when it was in sleep and i tried to turn it on, all there was was a black screen (and the BIOS set automatically the RAM back for 2133), as for the second time, i've left my pc on to download a game, in the morning (today in fact) i woke up to find that it blue screened, so after that i decided to try out some things, and i've found out that setting the memory back to 2133 would make the PC boot much faster (and probably more stable with it too, but i'm not sure).

Here a Some Userbenchmark Benchs i've done with the RAM on 2133 and 2933 :

http://www.userbenchmark.com/UserRun/4845196

http://www.userbenchmark.com/UserRun/4845252

http://www.userbenchmark.com/UserRun/4824860

So guys what do you think the problem is ! Sorry if my thread is too long and boring, and thanks in advance for any answer !
Reply to azizisalmane
No answers Last reply
More about slow pre windows bios boot ram
Ask a new question Answer

Read More

Overclocking ASrock RAM Slow Startup BIOS