Solved

Ryzen won't post with more than 1 stick of ram

I just built a new PC, spent hours trying to get windows 10 installed, and the only way I was able to do it was with 1 stick of ram

my build is
Ryzen 7 1700
MSI X370 Gaming Pro Carbon MOBO
GTX 1080 TI
Corsair Vengence LPX 3200mhz 16gb (2x8gb)

I have all of the latest drivers AFAIK, I updated the BIOS to 1.8 from 1.2, and now i'm stuck. If I put only 1 stick in (doesn't matter which one) windows 10 boots normally and runs fine. When I put a second stick in (according to my MOBO's diagrams I am in correct slot) my computer doesn't even post.

Edit: just bsod when trying to file transfer.
Reply to Rapple12
4 answers Last reply Best Answer
More about ryzen post stick ram
  1. Switch the RAM. The one installed and the one not installed and see if Windows is booting.
    If not, that stick is defective.
    If Windows is still booting, try to plug the RAM sticks in different slots combination...perhaps you read the mobo diagram wrongly.
    If it is still does not working...your mobo is defective
    Reply to guanyu210379
  2. Best answer
    make sure to put in the ram timings manually in the bios.
    Reply to keith12
  3. keith12 said:
    make sure to put in the ram timings manually in the bios.


    Thank You!
    16-18-18-18-38 solved all my problems and 100% stability! at 2933mhz
    Reply to Rapple12
  4. Rapple12 said:
    keith12 said:
    make sure to put in the ram timings manually in the bios.


    Thank You!
    16-18-18-18-38 solved all my problems and 100% stability! at 2933mhz


    super :) glad it worked. often the mem timings are overlooked when setting up. I've done it myself on occasion :)
    Reply to keith12
Ask a new question Answer

Read More

windows 10 RAM AMD