i7 980x underclocking problem

I was doing some underclock into my i7 980x since I was mining bitcoin with my gpu and didn´t want my cpu stressing too much. So, I set the multiplier to 22 (2,9 gHz). When I stopped I went to the bios and set the multiplier back to 26 (3,46 gHz) (a bit higher than the base clock). However, both the windows 10 task manager and CPU-Z say I'm still at 2,9 (gHz). At first, I tought it was just a visual glitch, so I went to GTA V and run the benchmark, and indeed it was getting lower FPS than previously. Then I run cinebench, And instead of the 665 I was getting, now it is 602. Do you guys have any idea on how to get back to, at least, the base clock? (I tried later setting the multiplier back to 25, which is the base multiplier, and it still didn't work)
My motherboard is the lga 1366 gigabyte guerilla killer, btw.
Reply to Breno_1
1 answer Last reply
More about 980x underclocking problem
  1. so as an update, I also tried later to underclock more the cpu to the multiplier 20, but it still would say 2,93 gHz. Do you have any idea on what is happening?
    Reply to Breno_1
Ask a new question Answer

Read More

Overclocking Intel i7 CPUs