Half Memory Hardware reserved. x64 bit os

So along with my previous article, I'm still stumped by this issue. Here is a short summary of what I have tried:

- MSCONFIG
- Update BIOS
- Swap RAM sticks slots
- Swap RAM
- Change Paging file size
- Clean RAM
- Re-seat CPU
- Contact Microsoft
- Contact G.Skill
- Contact Gigabyte
- Try New memory
- Try new GPU

So yea... I have tried basically everything. If you are unfamiliar with the issue it is basically that I have 8GB of ram installed. In About it says that there is only 3.97 Usable. If I go to task manager It shows that there is 4GB being reserved for hardware. I really tried to look around and find how to fix this but after a few MONTHS of searching nothing. My OS is windows 10 (x64) so it should be able to use all 8GB. I have tried to try different RAM thinking that possibly one stick is bad. I put in 4GB but then it takes that and puts 2GB for hardware. Even with different RAM it takes half and puts it to hardware. I checked my CPU for any bent pins but it looks perfect. BIOS is up to date and detects all 8GB and even shows 4GB in each slot. In CPU-Z though it shows only 4GB of RAM. If you go to the memory tab it is fully blank. The only thing shown is the size which says "4064 MB'' If I go to the SPD tab everything is empty. I even tried going through all 4 slots. They are all blank. I really don't know If this is a Windows error or a hardware error. Please let me know what is wrong and what I need to do to fix it. I'm all out of ideas. Thanks.

Forgot to mention that I used different ram in my system heres the results:
New RAM (4x2GB)
- Using 2x2GB PC Reserved 2GB
- Using 2x4GB PC Reserved 4GB

My RAM (2x4GB)
- Using 2x4GB PC Reserved 4GB
- Using 1x4GB PC wouldnt boot with either stick in any slot

I am using dual channel correctly. I am thinking it is a hardware issue possibly CPU now. Let me know what you think it is.

PC Specs:

- AMD FX 6300
- Gigabyte GA-970a-UD3P
- G.Skill Ripjaw X 8GB 2x4GB DDR3 1600
- MSI GeForce GTX 750ti OC 2GB
- EVGA 430W PSU
- Windows 10 Home x64

For more info here is a email I sent to AMD with no response yet:

Hello I have noticed that my PC is only allowing me to use 3.97GB of RAM out of my 8. If I go to task manager it says that there is 4GB Reserved for Hardware. I cant find out why it is doing this. I have come to belive that its a hardware issue.

Things I have Tried:
- Update BIOS
- Check Windows settings
- Reseat RAM
- Change RAM slots
- Reinstall windows
- Reseat CPU
- Swap RAM
- Swap GPU

So I have tried alot of things and they dont seem to help. I even tried putting in new RAM. If I have 8GB in it reserves 4GB. If I put in 4GB it reserves 2GB. Below is a diagram of my memory and results

Friends Memory In my PC:
8GB (4x2GB) 4GB Reserved for hardware
4GB (2x2GB) 2GB Reserved for hardware

My Memory In PC:
8GB (2x4GB) 4GB Reserved for hardware
4GB (1x4GB) System will not boot.

I have 4 slots usable for dual channel memory and if its in slot 1/3 it has this issue, and if its in slot 2/4 it also occurs. It seems odd that with only one stick of my memory the PC will not boot with either stick in any of the slots. However I dont think thats the issue because with all slots filled with my friends memory I still get this issue. I dont think its a memory issue and I also replaced the GPU. I dont have onboard video to reserve RAM for and even a Reinstall of Windows didnt solve the issue. I have Windows 10 64Bit so it should use all my memory and it did, when I first built my PC. It is only a recent issue. I updated the BIOs and looked at the settings but there is nothing for RAM. My conclusion it that it is a hardware issue from either my processor or my motherboard. Is there anyway to check or eliminate parts to really make sure?

Anyway I really hope someone can let me know what I have to do or what part to replace. I have tried contacting companies but they have been no help at all with really poor support.
Reply to JackM3
23 answers Last reply
More about half memory hardware reserved x64 bit
  1. Your comments about CPU-Z are very interesting, particularly the spd tab.. That is vital information encoded on the dimm for use by bios to determine the type of memory installed. Windows needs that vital info from bios to allocate and use ram effectively, so I think you on to something, either that or CPU-Z isn't compatible with your setup.

    https://en.wikipedia.org/wiki/Serial_presence_detect
    Reply to t53186
  2. I would say the two main things I don't "see" in what you did were
    A) Check PDF/Manual for Mobo maker to edit the video RAM on board, that would reserve that amount for 'hardware' and reduce it to 256MB or less
    B) Replace the Mono. Just updating the BIOS won't "change" the hardware if defective nor will reset (A) RAM set for video
    Reply to Tom Tancredi
  3. t53186: I thank you very much for the fast response! I wonder if that CPU-Z isnt compatible with my PC. I guess i should try to run it as admin ;( Sorry on my part. I really dont think that means much because all of CPU-Z was pretty empty with minimal information. BIOS detects all 8 and the slots they are in. I kind of think that there may be an issue with my CPU. What do you suppose? Thanks
    Reply to JackM3
  4. Tom Tancredi: Thanks for the response. Could you please rephrase your second answer. What is the Mono? Is that the CMOS battery? Sorry for the inconvenience. Thanks!
    Reply to JackM3
  5. Mobo* I meant to type, as in Motherboard itself.
    Reply to Tom Tancredi
  6. So you think its a motherboard issue or something messed with the bios?
    Reply to JackM3
  7. What Tom is telling you is to check if you mother board is reserving RAM for use with its onboard display adapter.

    If your motherboard supports integrated graphics (most consumer boards do these days) then there should be a setting in the BIOS for allocating some of your RAM for use as video RAM.

    If you are using a discrete graphics card (one not built in to your chip/board), just disable integrated graphics altogether.

    If you are using integrated graphics, then find the BIOS setting for choosing how much RAM to reserve as VRAM, and change that number to whatever value you can tolerate. Remember lowering the amount of VRAM you have can affect game performance, though if you are using integrated graphics, you probably aren't running any games that require 4GB of VRAM.
    Reply to bitwright
  8. I have a FX 6300 and CPU-Z recognizes all 8 GB of my RAM just fine. Before I was using integrated graphics on my motherboard, but earlier this year I added a GPU and switched from Windows 8 Pro 32 bit to Windows 8.1 Pro 64 bit, and as you can see from the image below, my hardware reserved is only 2.4 MB. I am using GSkill Ripjaws 1333 mhz (2 x 4 GB). I do have a different motherboard though.

    Reply to mjslakeridge
  9. Yea I dont have integrated graphics on my motherboard which is the weird thing. I tried a different GPU but same results. Thanks for the ideas. :)
    Reply to JackM3
  10. Maybe try getting the latest version of CPU-Z. (I think it is 1.80.1). I am on the next to latest version and the SPD tabs have no problems identifying the RAM.

    Reply to mjslakeridge
  11. Just re downloaded it. When I open it it comes up with and error bod that says: The Error Code 0x5 (5) occurred during initialization. Do you want to display the error log file? Then if i hit no it loads anyways. When I open CPU-Z it looks normal on the processor tab but the memory tab it is all blank and says Size: 4064 MBytes. SPD is empty in every tab.
    Reply to JackM3
  12. Does the bios see the ram? I would have to agree with Tom and think its the motherboard at this stage. windows isn't going to effect anything that happens at boot up, and you say PC won't boot with certain combos regardless of which ram is in it?
    Reply to Colif
  13. It does seem like a motherboard issue to me also. You may want to download and run memtest64, on one stick of RAM at a time, just to rule out bad RAM. To run Memtest64, you install it to a CD or USB flash drive, and go in to the BIOS to select the CD or USB flash drive as the first boot option and save and exit. That way, you boot into Memtest64, and not Windows. You can let it run for a couple of hours on each RAM stick.
    Reply to mjslakeridge
  14. he used his friends ram as well, so its unlikely to be the sticks, but memtest may tell us what slots don't work though.
    Reply to Colif
  15. Ya, I thought about that too. Unlikely, the friend's RAM was bad also.
    Reply to mjslakeridge
  16. Yea. Bios recognizes all 8GB. If I change motherboard slots it still does the same thing. I really dont think its the motherboard. My friends ram also did the same when using 2 sticks in 2 slots or 4 sticks in all slots. Whatever I have it cuts it in half.
    Reply to JackM3
  17. It has to be something with Windows that is setting the amount of Hardware Reserved memory. As I said above, when I installed my GPU, installed new ram (went from 2 x 2 to 2 x 4GB), and installed the 64 bit version of Windows 8.1 Pro, my Hardware Reserved went from something like 750MB to the current 2.4MB. I made absolutely no changes to the BIOS settings.

    What is troubling is that CPU-Z is also acting strange in your case. I really don't know what to say. I don't think it is a bad Integrated Memory Controller in the CPU, because if that were the case, it probably wouldn't recognize all 8GB, rather than Hardware Reserving half of it.

    If you Google "setting hardware reserved memory", there are a lot of results. This link to a Youtube video shows how to fix it with a registry edit.

    https://www.youtube.com/watch?v=oFK2eB51_Ss
    Reply to mjslakeridge
  18. Did you try loading a Ubuntu liveusb or cd on PC and see if it can access all the ram? That would tell you if it is windows or not. You can run off the dvd/usb, don't need to install it. As I suggested in your other question, try making this on another PC: http://www.howtogeek.com/howto/windows-vista/use-ubuntu-live-cd-to-backup-files-from-your-dead-windows-computer

    Problem I see with using ubuntu is win 10 is more picky with its ram compared to even win 7 and will report ram as bad that win 7 would be happy to use. Probably tied into how win 10 uses ram now, in both fast startup (since it suspends win 10 to ram and page file while its turned off) or ram compression (when you close a program in win 10,m instead of dumping all the data from closed program onto hdd, it compresses it in ram in case you reopen same program again, its faster to load then). So ubuntu might show you have 8gb it can use... still worth a look though.
    Reply to Colif
  19. Dont you think that it would all be solved be my reinstall of windows? I had all 8 but then about 2-3 months ago I noticed lack in performance.
    Reply to JackM3
  20. You said in your first post that you already reinstalled Windows. You could try it again, but I doubt you would get a different result.

    Did you see the YouTube video link I posted in my last response above? (I added it after my initial response, but forgot to say I had edited my post, so maybe you didn't see it). He solved the exact same issue with a registry edit.
    Reply to mjslakeridge
  21. It could also be you CPU, these days the memory controller is built into the cpu and it's possible the memory controller not working as it should.
    Reply to Kasper Jorgensen
  22. what is the specific part number on the ram?

    Are you overclocking at all?

    what are your cpu vcore/ cpu nb/ cpu VDDA/ and DRAM voltages showing?
    Reply to maxwellmelon
  23. Thanks for the responses. I already tried the things in the YouTube video. Also here is a link to my RAM. Im not overclocking at all. https://pcpartpicker.com/product/LzTmP6/gskill-memory-f312800cl9d8gbxl
    Reply to JackM3
Ask a new question Answer

Read More

Hardware RAM AMD Memory