LED's on MOBO and GPU lighting up but no POST, please help!

So I decided to help my friend build a pc and it has been all but easy. I have already built mine plus another friends but the issue lies in POSTing. I have already RMAd a good chunck of the parts once.

Heres what happens:
I boot it, LEDs light up and everything seems to run fine, but I get no video signal on the monitor. I tried both HDMI and VGA. I thought it was the RAM type but I have seen most people saying that even if it says "supports intel" it can still be used in an AMD build. Please help. How long should this thing take to post (I heard that AMD takes a while)? what could be the probably cause? I feel so bad about reccomending the parts and not being able to get it to POST. The worst part is that I have tried to put the video output with both the graphics card installed and taken out. I legit don't know if I should just let the mobo run and let it take its time or if I should return a part. I can't really test any of the parts on another build because mine is intel without DDR4 support.

Parts:
AMD RYZEN 5 1600 (CPU)
ASRock Fatal1ty AB350 Gaming K4 (MOBO)
SanDisk SSD PLUS 2.5" 120GB (Boot drive)
G.SKILL Ripjaws V Series 8GB 288-Pin DDR4 SDRAM (RAM)
SeaSonic G Series SSR-550RM 550W ATX12V / EPS12V (Power Supply)
GIGABYTE GeForce GTX 1050 Ti (GPU)
Reply to sub_mordekai
10 answers Last reply
More about led mobo gpu lighting post
  1. It will not post without graphic card and monitor plugged in it. Ryzen 5 doesn't have a GPU built in.
    Reply to CountMike
  2. I plugged the gpu in yet it still has not POSTed.
    Reply to sub_mordekai
  3. When you plugged the GPU in, is your monitor still connected to the motherboard's video outputs? Make sure you use the GPU's video outputs instead. As said above, Ryzen CPUs don't have integrated graphics, so, your motherboard will not output any video signals from its output ports.
    Reply to raisonjohn
  4. I plugged it into the HDMI port on the 1050. Now I can do another test run this weekend but the issue is that I don't know how long it should take to post. What's the average for ryzen? My i5 when I first built it took maybe a couple of minutes but this seems to be taking forever. Should I leave it running all night?
    Reply to sub_mordekai
  5. All knight would be way excessive. it should post first time in a minute or two. Clear the CMOS before first start while disconnected from power.
    Reply to CountMike
  6. SO I put the cap on to clear the CMOS and I forgot I had taken out the RAM, the MOBO continued to restart every few minutes. I placed the RAM in a slot and the MOBO stopped restarting and started sounding like the it was short circuiting (the "Fan Stop" light on my gpu kept turning on and off and my cpu fan was starting and stopping every 10-30 seconds consistently) . Is this a RAM issue? the SSD is not plugged in however I think it was doing this without it. I still cannot get a POST screen.

    ALSO this is all being done outside the case while the MOBO is resting on the black sheet thing it came in (I don't know exactly what the material is called)
    Reply to sub_mordekai
  7. Did you unplug computer while doing all of that ? You can do serious damage if you do any of that while it's live.
    Reply to CountMike
  8. I turned off the power supply with the switch that is built into it and then put the RAM in. I put the cap to clear CMOS on while the MOBO had not been plugged in for a while.
    Reply to sub_mordekai
  9. UPDATE: I am almost certain it is the RAM short circuiting or defective. When the RAM is taken out, the MOBO boots, then restarts and does that cycle every few minutes or so. When the RAM is placed in the slot, the GPU and CPU Fan consistently start for 10-30 seconds then stop then start again. If I am wrong in my assumption, please tell me before I RMA.
    Reply to sub_mordekai
  10. Hello I had this same issue with my system a while back. I had my PC where it would turn on and run for a bit but there was no display on the monitor. I tried to RMA the mobo and I put it in the system and had the same issue. I sent back the CPU and it worked fine. Dead CPU's cause this. The best way to check is to try and use your mobo display output insted of the GPU. If you get a boot its the GPU otherwise I would say CPU or mobo.
    Reply to JackM3
Ask a new question Answer

Read More

Build