Memory_Management, IQRL_Not_Less_Or_Equal, Bad_Pool_Header and more BSODs, but no memtest errors.

For around the past 3 months or so, I've let countless bluescreens plague my PC, anywhere from 1 to 3 times a day, with only a few days without them completely. (Frequency of different BSODs below)
0x0000007e 1 System Thread Exception Not Handled
0x00000050 17 Page Fault in NonPaged Area
0x000000be 2 Attempted to write read only memory
0x0000003b 2 System Service Exception
0x0000000a 4 IQRL Not Less Or Equal
0x000000d1 1 IQRL Not Less Or Equal
0x000000ef 1 Critical Process Died
0x00000139 1 Kernel Security Check Failure
0x0000001a 1 Memory Management

From what I've been able to gather, the BSODs are pretty much all are related to RAM in some way. The only problem is that, after running Memtest86 for around 14 passes, and running MS Memory Diagnostics, neither one came up with any errors whatsoever. I've come to my wits end trying to figure out what the problem is, and I would truly love to have a (mostly) non-BSOD riddled experience while using my PC. I should be able to provide any other information that could help, provided you tell me where/how to find it. Any help is appreciated, and Thanks!
(PC Specs)
Intel Core 17, 6700k CPU
NVidia GTX Geforce 1080 GPU
MSI z170a Krait Gaming 3x Mobo
Patriot Signature Line, DDR4 32Gb (4x8gb)
Windows 10 Home 64bit
Reply to chawork1234
21 answers Last reply
More about memory management iqrl equal bad pool header bsods memtest errors
  1. Can you upload the files from C:\Windows\minidump?
    Reply to okcnaline
  2. okcnaline said:
    Can you upload the files from C:\Windows\minidump?

    Would you like all of them in a zip/rar archive, or can I upload them in plaintext somehow?
    Reply to chawork1234
  3. Rar will be fine.
    Reply to okcnaline
  4. Reply to chawork1234
  5. okcnaline said:
    Can you upload the files from C:\Windows\minidump?


    Just a quick bump to help visibility.
    Reply to chawork1234
  6. Full specs?
    Reply to okcnaline
  7. okcnaline said:
    Full specs?


    -Intel Core 17, 6700k CPU
    -NVidia GTX Geforce 1080 GPU
    -MSI z170a Krait Gaming 3x Mobo
    -Patriot Signature Line, DDR4 2400mhz 32Gb (4x8gb) Ram
    -Windows 10 Home 64bit OS
    -WD Black HDD 7200 RPM, 2TB storage
    Reply to chawork1234
  8. PSU?
    Reply to okcnaline
  9. Corsair RM750i, and my CPU cooling is a Corsair H110i GT
    Reply to chawork1234
  10. Oh gee, I don't have an idea. The BSODs are all not correlated (some point to drivers, some to RAM, some to what seem like PSU). Lemme ask for help.
    Reply to okcnaline
  11. Nice to know I'm not overlooking something obvious. It's late here(2AM), so I may or may not respond if you reply soon, but I will as quick as I can tomorrow. Thanks for the ongoing help!
    Reply to chawork1234
  12. Try going to MSI web site for motherboard, go to the service/utilities page and download live update 6. run it and make sure you have latest drivers for motherboard. I will ask someone to look at dump files and see what else might be to blame
    Reply to Colif
  13. Is XMP enabled in the bios/uefi for the ram?
    Tried with just two sticks? Use slots 2+4 counted from the cpu. Can switch sticks as well. Even memtest can be wrong.
    Reply to Vic 40
  14. Thanks Colif and Vic. I'm not sure when I'll be back at my computer, but I'll update/verify my BIOS/UEFI version, and I'll start a memtest run on 2 sticks of ram before I go to bed. I'll do the next test sometime later in the night if it makes enough passes, and if I wake up for it. Any things for me to think about in the meantime?
    Reply to chawork1234
  15. Hi, I ran the dump file(s) through the debugger and got the following information: https://pastebin.com/bCh3G8TE

    File: 081317-33734-01.dmp (Sun Aug 13 16:56:36 2017)
    BugCheck: [PAGE_FAULT_IN_NONPAGED_AREA (50)] {ffff80897c4fca4c, 0, fffff80005b54170, 2}
    Probably caused by: memory_corruption (Process: Rainmeter.exe)

    File: 072817-23343-01.dmp (Fri Jul 28 21:26:32 2017)
    BugCheck 1, {7ff8661a5a64, 0, ffff, ffffa980a7d87b00}
    Probably caused by: ntkrnlmp.exe (Process: WmiPrvSE.exe)

    File: 073017-19421-01.dmp (Sun Jul 30 23:45:32 2017)
    BugCheck: [PAGE_FAULT_IN_NONPAGED_AREA (50)] {ffffac04de821a4c, 0, fffff800a2150170, 2}
    Probably caused by: memory_corruption (Process: ENBInjector.exe)

    File: 080117-24359-01.dmp (Tue Aug 1 19:58:00 2017)
    BugCheck: [PAGE_FAULT_IN_NONPAGED_AREA (50)] {ffffaa012486268c, 0, fffff8021315b170, 2}
    Probably caused by: memory_corruption (Process: Rainmeter.exe)

    File: 081017-33859-01.dmp (Thu Aug 10 03:41:35 2017)
    BugCheck: [SYSTEM_SERVICE_EXCEPTION (3B)] {c0000005, fffff5e9eae44ba0, ffffb7006a4fcd00, 0}
    Probably caused by: memory_corruption (Process: Rainmeter.exe)

    File: 081117-27484-01.dmp (Fri Aug 11 02:16:08 2017)
    BugCheck: [MEMORY_MANAGEMENT (1A)] {41201, ffffb180e1c4fd40, 81000001fbb38867, ffff8000cbf1cca0}
    Warning: Unable to verify timestamp for: aswSnx.sys
    Probably caused by: aswSnx.sys (Process: dwm.exe)

    The following 2 files were 0 bytes long which means they were invalid:
    080817-36015-01.dmp
    081317-29906-01.dmp

    You have BIOS version: 2.50
    The lastest BIOS for your system is: 7A11v29 (That basically means version 2.90)
    Verify the link below is correct and then consider updating.
    https://us.msi.com/Motherboard/support/Z170A-KRAIT-GAMING-3X.html
    I don't know if this will help or not, however, what it says on the page about this BIOS is: Improved memory compatibility problem.

    The aswSnx.sys file is a part of Avast anti-virus. You have a few choices: 1. Make sure you have the latest updates for Avast and Windows. 2. Uninstall and re-install Avast. 3. Uninstall Avast (at least temporarily until we figure out why you are crashing). The Avast homepage can be found here: https://www.avast.com/

    I can't help you with this. Wait for someone else to reply. Good luck.
    Reply to gardenman
  16. Thanks garden, I'll disable/uninstall avast when I get home as well as update my BIOS. Thanks for the help!
    Reply to chawork1234
  17. other older drivers that won't help:

    Anything before July 2015 isn't a win 10 driver and might cause hassles. I would update or remove anything below:

    inpoutx64.sys (Dated Fri Oct 17 2008) - inpoutx64.sys is part of inpoutx64 Driver Version 1.2 and developed by Highresolution Enterprises [www.highrez.co.uk]. Not sure what this is part of - http://www.highrez.co.uk/downloads/inpout32/ (its way too old to work with win 10)
    your copy of vmware is from 2014
    npf.sys (Dated Thu Feb 28 2013) - NetGroup Packet Filter driver, a component of WinPCap by Riverbed
    vbaudio_vmvaio64_win7.sys (Dated Mon Apr 21 2014) - Do you have something called Voice meter on PC? Virtual Audio cable
    Hamdrv.sys (dated Mon Mar 30 2015) - LogMeIn Hamachi Virtual Miniport driver
    netr28ux.sys (Dated Thu May 28 2015) - Ralink Wireless Adapter Driver - this might be tripping avast over
    tapse01.sys (Dated Thu Jun 11 2015) - This files most often belongs to product TAP-Windows Virtual Network Driver. and were most often developed by company The OpenVPN Project.
    Reply to Colif
  18. -Hi Rez driver is probably from an old Smite installation Same name, different company. Not sure what exactly that's from Used XMB on a whim to fix a mouse issue in a game. Must not have uninstalled it. (Does the amount of unused, uninstalled software on my PC say something about me?)
    -ill look at updating VMware soon, but I should be fine uninstalling it for now as I'm not using it as much as I used to.
    -I do consistently use Voicemeter and Virtual Audio Cable for better control of my system audio, but I'll look at reinstalling/updating them and their drivers
    -I'll also look at updating Hamachi's drivers
    -That was the driver that was shipped with my wireless Desktop adapter, out of curiosity what makes you think that's the problem with avast?

    If I update the programs, should that replace the old, possibly problematic versions of the drivers, or do I need to manually delete them from somewhere?
    Reply to chawork1234
  19. Win 10 curators edition seems to have messed with the dates on some network drivers, so updating them may fix the problem.

    As for avast, well... the wireless adapter driver is the only LAN driver mentioned so you could say its a guess.

    Updating programs "should" delete the old drivers as they install. Not all do but we can hope they work right.
    Reply to Colif
  20. Got home, Update on what I've done so far.
    -Avast Uninstalled (I run weekly scans with MalwareBytes anyways, unless I unknowingly install Memz, I should be fine.)
    -Updated every driver on my PC I could find w/ the help of a driver update tool to find everything.
    -Downloaded BIOS update to USB drive, will update in a second.
    -Ran SFC /Scannow, got an interesting message
    Windows Resource Protection found corrupt files but was unable to fix some
    of them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For
    example C:\Windows\Logs\CBS\CBS.log. Note that logging is currently not
    supported in offline servicing scenarios.

    Not sure if the wall of text it provides is of any use, but I'll leave it here anyways (Would've put it in pastebin, but it exceeds the size limit..)
    Reply to chawork1234
  21. right click start button
    choose powershell (admin)
    copy/paste this command into same window:
    Repair-WindowsImage -Online -RestoreHealth and press enter
    re run SFC after this and it should be able to fix those files, then restart PC

    if that comes back with an error about Source, do this:
    Download a copy of the win 10 iso from Here - create ISO by telling it you want to make DVD - and then mount that ISO in file explorer (see Here) and then copy paste the below command into command prompt (admin)

    DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:X:\Sources\Install.wim:1 /LimitAccess
    Where "X" is the drive letter where the ISO is located. Simply change the "X" to the correct drive letter
    Reply to Colif
Ask a new question Answer

Read More

windows 10 Blue Screen Memory Management Memory