Solved

New Ryzen build won't post (I'm new to this)

Greetings every body, finally decided to build my own computer with the following major components

Motherboard: ASRock A320M-DGS
CPU: Ryzen 3 1300x
Graphics: EVGA GTX 1050 Ti
RAM: G.Skill Ripjaws V 2400 8GBx1
PSU: EVGA 500 BQ

after watching numerous build videos and learning that i should make sure my parts work before installing everything into my case, i did just that and to my surprise i could not get my system to POST
my fans would turn on but i would hear no sort of beep (i dont think the motherboard comes with a speaker for this, no light either)
i reseated the cpu several times and adjusted the pressure on the cooler, i heard this was an issue sometimes, i double checked to make sure all my connections were solid and my ram (tried both slots) and graphics were seated properly as well. The motherboard does include on-board graphics so i tried that output and still nothing (though I've heard risen 3 doesn't support on board graphics). I read my motherboard manual and did the whole clear cmos thing as well and still nothing. I did read a couple reviews on Newegg where i purchssed the motherboard and saw reviews of a couple people receiving theres DOA. I want to try to see if i can get mine to start before i declare it DOA. Could it be that my ram is incompatible? I did try to start it without ram as well and nothing there either. My graphics works on my other computer but i have no way of diagnosing a bad cpu if thats the case. prior to making my purchase I heard risen takes forever to post on the first time but I've given my system minutes to post after trying all the troubleshooting there is to do and nothing happens. Im lost and need help since i am pretty new to this. I appreciate the replies if any, thanks!
Reply to oddcesarr
5 answers Last reply Best Answer
More about ryzen build post
  1. Best answer
    Hi,
    The CPU is not listed on the http://www.asrock.com/MB/AMD/A320M-DGS/#CPU
    It might be that the board's BIOS needs an update.
    Reply to alexoiu
  2. alexoiu said:
    Hi,
    The CPU is not listed on the http://www.asrock.com/MB/AMD/A320M-DGS/#CPU
    It might be that the board's BIOS needs an update.


    I had not noticed it isn't listed on their support page, how would I go about updating the bios if I cannot get it to display anything, thanks for replying!
    Reply to oddcesarr
  3. No problem.
    You can't without a supported CPU. Try contacting ASRock, see what they say.
    Reply to alexoiu
  4. alexoiu said:
    No problem.
    You can't without a supported CPU. Try contacting ASRock, see what they say.


    yea they just sent me the good ol troubleshooting list that I had already been through, I ended up with an RMA anyway cause I would not have been able to borrow someone else cpu to get in and update the bios to see if it would even work. I thank you so much for helping me with this, people were being assholes everywhere else cause "it says its compatible right there *inserts product description saying it supports ryzen*"
    Reply to oddcesarr
  5. You're welcome.
    Reply to alexoiu
Ask a new question Answer

Read More

Build Motherboards