Solved

Front panel mic jack not working

Hello,

I have tried multiple other suggestions found on this website, and others, to no avail. My front microphone input jack (pink) is not working correctly: the microphone shows up in the Recording devices of the Sound control panel as "Microphone; VIA HD Audio(Win 10)" and is set as the "Default Device". However, all I hear from it (when "Listening to this device" in Windows's microphone properties) is a constant humming/buzzing sound, which quickly becomes loud static.

The microphone is from 2-in-1 earphones going into a splitter. The back port for microphone is working just fine, but I'd rather not have to buy a cable extender. The front and back ports for audio output are both working. A USB mic I own works fine.

I have tried:
- Checking that the appropriate audio devices are shown in the Sound control panel and are set to be the default devices
- Installing Windows Updates
- Uninstalling and reinstalling VIA HD audio drivers via the Windows Device Manager (have tried the latest VIA audio driver from their own website, as well as the one from the Support section for my specific motherboard on ASRock's website)
- Checking the cable connections on the motherboard itself
- Enabling onboard sound in the BIOS options (the onboard sound is set to "Enabled", however front panel only had the options "Auto" and "Disabled", so I set it to "Auto"
- Tried with two different splitter cables

OS: Windows 10 Pro 64-bit
Motherboard: ASRock H61M-VS

Thanks in advance for any help!
Reply to Andrew_343
3 answers Last reply Best Answer
More about front panel mic jack working
  1. 1| Have you made sure your motherboard BIOS is up to date? It looks like you migrated to Windows 10 from an older OS.
    2| Can you pass on a link to both the splitter cables and how they are connected in your system? I'm ruling the front ports(on your case) out as faulty so we're talking about connecting off the rear I/O audio ports.
    3| Can you also state the make and model of your headset?
    4| Have you used another headset and seen if the that is also causing the same issue?
    Reply to Lutfij
  2. Thanks for your reply.

    1. I download and installed the BIOS update from the ASRock website; no difference.
    2. The two splitter cables I tried were actually just two of the same (they sent me two, for some reason). This is the specific one: https://goo.gl/aa3R38
    3. The headset is the Betron W58: https://goo.gl/7CMuj1
    (I have tested the headset plugged in to my phone, and the mic works fine there, too.)
    4. I don't have access to any other headsets at the moment, but I will see if I can get my hands on one to test it out.

    Just to be clear, I can use this setup (headset --> splitter cable --> I/O jacks) if I go into the back of the PC and it seems to work fine. It's only the front input jack that's causing problems. So, as I said, I could just get an extender cable or two. However, I have a pair of speakers plucked in to the rear output jack, and I would like to be able to quickly swap between it and my headset without having to go around the back of the tower.
    Reply to Andrew_343
  3. Best answer
    I had a similar problem with a Gigabyte motherboard, also using a VIA audio chip. The front panel headphones worked OK, but the microphone wouldn't. I had to use an extension cable from the back of the case.

    What fixed it for me was going in to the "VIA Deck" audio software (usually installed with the drivers) and unchecking the "Enable front panel jack detection" option.


    Click the gold tool icon (Advanced options) then uncheck the circle (it will go from blue to gray) for front panel jack detection, then try the front panel mic jack again. My understanding is that AC97 front panels (which the vast majority of PC cases have) do not have front panel jack detection capabilities, so it needs to be disabled.

    If you don't have the VIA Deck running (and you may not... in my case it installed the 32 bit version by default, and then wouldn't run because of it being a 64 bit version of Windows), then get the .zip file for the audio driver here (you'll have to use Windows 8.1 64 bit as there doesn't seem to be a specific Win 10 version)

    http://www.asrock.com/mb/Intel/H61M-VS/index.asp#osW8164

    ... then unzip it and find the VDeck application inside the unzipped folder this way:
    Open the "VIAHDAud" folder; Then open the "Present" folder; finally open the "VDeck 64" folder.
    You can then just click the VDeck.exe and run it (no need to install).
    It seems that once I unchecked the front jack detection option I was good to go. No need to run VDeck with startup every time or anything like that.

    Hope this works for you!
    Reply to dave_b77
Ask a new question Answer

Read More

Microphone VIA ASrock Front Panel Devices Motherboards Audio