Solved

usb is giving me a hard time

hi everyone. After i lent my usb drive to my friend,each time i plug the usb in, windows will ask me to format this drive before using it, when i try to do so,a window pops that says disk is write protected,i tried almost every method to solve this issue but nothing works
additional info about the statues of the usb:
when i tried the dikspart method in cmd : current read only state:yes
read only: no
when i click on properties in the graph section it says: free space:0 space in use: 0 (what ???) also the drive is not raw format instead of NTFS
i also can't access the usb because a window pops up that says: the volume does not contain a system files check if all drivers are installed or if the volume is not corrupted.

sorry for my bad english btw i hope i provided a clear description of the matter.
would really appreciate some help
thanks!
Reply to NASSIM_1
4 answers Last reply Best Answer
More about usb giving hard time
  1. Dead duck.
    Reply to CountMike
  2. CountMike said:
    Dead duck.


    so does that mean i should consider buying a new one?
    Reply to NASSIM_1
  3. Best answer
    Yes sir, the symptoms you described are most common for failed USB memory.
    Reply to CountMike
  4. well, that's unfortunate, anyway thanks for the help !
    Reply to NASSIM_1
Ask a new question Answer

Read More

Windows Read Only USB USB Drive