Solved

Maximus iX Hero - no display, new build!

Hey guys!

Recently built a new pc, here are the specs;

Mobo - Maximus iX Hero
CPU - 7700 i7 1151
GPU - GTX 1080 Strix Asus OC edition
Ram - x2 8g DDR4 Corsair Vengeance LPX 2400MHz
H100i v2 Liquid Cooler
CX 750M Corsair Power Supply
570x Corsair Crystal Case

So this is my real first high end gaming pc, I've built one cheap gaming desktop 5-6 years ago, but that's all.

Followed instructions and guides on plugging things in, so everything should be properly plugged in. I've gone through and pulled everything to make sure it's all teethed properly. The issue is that my display is not showing up after pressing the power on button. When attempting to boot up my pc all LEDs turn on, all 8 fans are running. ( 3 on GPU, 2 at radiator for the cooler and the 3 on the side of the case ) All parts installed have power because their LEDs are lighting up. The Q Code is throwing the code 53 which is " memory initialization error. Invalid memory type or incomparable memory speed " but when looking back at the MOBO specs and compatabilities it says the 2400MHz is compatible. I've tried booting up the pc with one stick, tried all 4 slots with both sticks in / each one alone as well.

I've done just about every troubleshooting instance besides dropping the flash bio into the comp. Please help!
Reply to Skullcrow719
8 answers Last reply Best Answer
More about maximus hero display build
  1. Hi, Have you properly inserted the RAM module in the slot? Some require a bit more force. Do both latches come in place, when RAM inserted?
    Reply to alexoiu
  2. @alex yes both sticks are securely placed into slot 2 and 4 as recommended in the mobo manual. The latch on top of slots clicked when inserting both sticks of ram.
    Reply to Skullcrow719
  3. Try borrowing a RAM module and testing, if possible. Another option would be RMA-ing both board and CPU.
    Reply to alexoiu
  4. Had the same problem and we have almost the same parts.
    Reason was faulty ram modules.
    Reply to lumineZ
  5. @luminez yeah from looking at what people have posted recently on this site, it seems to be a bad MOBO or RAM.
    Reply to Skullcrow719
  6. Did you just swap the ram out and it booted up?
    Reply to Skullcrow719
  7. And did you ever boot up without any ram installed onto your comp? It still flashes Qcode 53 when I do this instead of code 55 which would be "memory not installed". Because it keeps this code 53, I feel as if it's a mobo issue.
    Reply to Skullcrow719
  8. Best answer
    Skullcrow719 said:
    Did you just swap the ram out and it booted up?



    First I had to update bios.
    Then I could not run XMP or set manual speed higher than 2933mhz on the ram
    So I tested them and one was faulty.
    So I got a new kit and 0 problems after that.
    Reply to lumineZ
Ask a new question Answer