Solved

NZXT S340 Elite Power Button Led Not Lighting up when i turn on my computer

NZXT S340 Elite Power Button Led Not Lighting up when i turn on my computer i have my front panel connectors plugged in to the jfp1 header according to the order on the manual.
Reply to TheNerdyTimeLord
12 answers Last reply Best Answer
More about nzxt s340 elite power button led lighting turn computer
  1. If connecting it to the HDD LED, does it work?
    Have you tried reversing polarity?
    Reply to alexoiu
  2. alexoiu said:
    If connecting it to the HDD LED, does it work?
    Have you tried reversing polarity?


    This is my first build can you please simplify that I think reversing the polarity is switching + and - if so I've tried that.
    Reply to TheNerdyTimeLord
  3. alexoiu said:
    If connecting it to the HDD LED, does it work?
    Have you tried reversing polarity?

    And the hdd led cable is at the bottom
    And my motherboard is the Z270 MSI Gaming Pro Carbon
    Reply to TheNerdyTimeLord
  4. Just connect the Power LED on case to the HDD LED pins on board (at the bottom), to test if LED working.
    Reply to alexoiu
  5. alexoiu said:
    Just connect the Power LED on case to the HDD LED pins on board (at the bottom), to test if LED working.


    Ok I'll try that.
    Reply to TheNerdyTimeLord
  6. alexoiu said:
    Just connect the Power LED on case to the HDD LED pins on board (at the bottom), to test if LED working.


    Nope Still not lighting up
    Reply to TheNerdyTimeLord
  7. Best answer
    Then it might be a defective LED, or a broken wire.
    Reply to alexoiu
  8. alexoiu said:
    Just connect the Power LED on case to the HDD LED pins on board (at the bottom), to test if LED working.


    alexoiu said:
    Then it might be a defective LED, or a broken wire.


    Both Leds won't light up
    Just to make sure i switched the hdd led wire with the p led (+ on the right and - on the left)
    Reply to TheNerdyTimeLord
  9. alexoiu said:
    Then it might be a defective LED, or a broken wire.


    And i Still haven't completed the build so i still need to get ram and cpu
    Reply to TheNerdyTimeLord
  10. Then wait for the CPU and then test.
    Reply to alexoiu
  11. alexoiu said:
    Then wait for the CPU and then test.


    ok do you think that will fix the issue btw thanks!
    Reply to TheNerdyTimeLord
  12. No problem.
    Yes. Definitely.
    Reply to alexoiu
Ask a new question Answer

Read More

NZXT Computers Elite LED Monitor Power