disk not initialized, but can still see files (data error cyclic redundency check)

One of my seagate hard drives has started acting up. As the title says, disk manager says it's not initialized, and prompts me to initialize it, but when I try to (both GPT and MBR) it gives a data error cyclic redundancy check. I can still see the drive in windows and browse the files, but I cannot move or copy them to another drive.

I have tried checking and repairing the disk for errors-dumbf windows says everything's fine. Same with Seatools diagnostics, and chckdsk from the command prompt. Everything says it's fine, yet no matter what I do, no program I've tried (many, including the unstoppable copier) have been able to get any of the files off

I have a feeling it's bad sectors, but like I said, nothing so far has been able to repair it or get the files off.

And before anyone yells at me about backups, this is a brand new drive and system that I haven't had the chance to set up backups for yet. Like literally just finished building
Reply to wuubb
1 answer Last reply
More about disk initialized files data error cyclic redundency check
  1. We are sorry to hear you're having trouble with your drive. You mentioned having already run SeaTools, we just wanted to make sure you've run the long generic test and not just the shorter tests? The long generic can take awhile, but it tests all of the sectors rather than just randomly sampling areas. You could also try using a different cable or port and see if the issue persists.

    If you'd like, you can get in touch directly with Seagate Customer Support here.
    Reply to seagate_surfer
Ask a new question Answer

Read More

Hard Drives Disk Error Windows Seagate Chkdsk Disk Read Error