New Ryzen + X370 Taichi Build wont POST

Hey there,
I recently put together a new computer, and I can't get it to post. It's in a reset loop and I can't find any info on the manufacturers website, or on the web.
Here are the specs.
ASRock X370 Taichi AM4 AMD Promontory - Motherboard
AMD RYZEN 7 1700 8-Core 3.0 GHz - CPU
EVGA GeForce GTX 1080 Ti SC2 GAMING - GPU
G.SKILL TridentZ Series 16GB (2x8 288pin) - RAM
SAMSUNG 850 EVO 2.5" 500GB - SSD
WD Blue 2TB Desktop Hard Disk Drive - HDD
CRYORIG R1 Universal Dual Tower Heatsink - Cooling
EVGA SuperNOVA 750 G3, 220-G3-0750-X1, 80+ GOLD - PSU

The motherboard has a LED display which last night was displaying a bunch of different numbers, before settling on 1f.
This morning after taking it apart and putting it back together, the number is now 46 or 4b, it's difficult to say which.
I've tried running one or both sticks of ram, in different slots, as well as running with or without all of the components. I feel like I've tried every combination and I'm a bit stuck.
It stays on for maybe 20 seconds or so before rebooting, and while idling and off the motherboard has a pulsing blue light on.
If you need any more information let me know.
Does anybody have any ideas as to what could be going on?
Thanks so much - Andrew.
Reply to andrewbzucchino
2 answers Last reply
More about ryzen x370 taichi build wont post
  1. Sounds like something could be shorting out your motherboard. Have you tried removing it and checking everything that's underneath it?
    Reply to g-unit1111
Ask a new question Answer

Read More

EVGA ASrock Homebuilt Computers AMD BIOS Hardware Problem windows 10 System Error Help Desk New Build