Solved

Mushkin ECO SSD boot drive won't boot, doesn't show up in BIOS.

Hello. About 2 years ago, I built my first computer. All went well. I installed Windows 7 on a Mushkin Eco2 120GB SSD, then upgraded to Windows 10. I haven't had a single issue with the computer until now. I went to turn it on, and was prompted with a black screen telling me to reboot and select the correct boot drive. Upon rebooting into the UEFI, the drive no longer shows up as a boot option. I have tried a different SATA cable, and a different header on the Mobo. I don't believe it is the power cable, as its one of the ones with several headers, and two of the others are connected to the DVD reader/writer and the HDD, both which show up fine, and I also tried powering the SSD with another power header and that made no difference. I reset the BIOS settings, also to no avail. I'm bound to think that the drive failed unfortunately. At least it's still under warranty. Anything else I might be able to try?

Full PC specs in case they might be of use:
Intel i7 4790k
Cooler Master Hyper 212 Evo
EVGA GeForce GTX 960 SC
8GB G.Skill Sniper DDR3 1866
ASRock Z97 Anniversary Mobo
EVGA 600W 80+ Bronze PSU
WD Blue 1TB 7200RPM HDD
Mushkin ECO 120GB SSD

Thanks!
Mark
Reply to higuys23
1 answer Last reply Best Answer
More about mushkin eco ssd boot drive boot show bios
  1. Best answer
    Probably failed , My son had 2 of them and they both failed in under a year , now I go with Samsung and Crucial only.
    Reply to SR-71 Blackbird
Ask a new question Answer

Read More

Mushkin SSD Storage Boot BIOS