Asrock AB350M not posting

Just got all new components, put it together and no display. Everything lights up, fans spin but no display. Removed all unnecessary wires, RAM, VGA and still no beeps. Yes, beeper is connected. PSU and VGA tested and confirmed working in another system. Standoffs properly installed, ground strap used, CPU reseated and connectors are flush. I suspect incompatible memory but shouldn't I at least get some beeps with no RAM installed?

Asrock AB350M
Ryzen 5 1600
Corsair Vengeance LPX DDR4 3000
Evga Nvidia GTX 1060 6GB SC
Samsung 960 EVO 250GB
Corsair CX650 PSU
Reply to Slick_3
6 answers Last reply
More about asrock b350m posting
  1. If removing all RAMs and starting the board, still no beeps?
    Reply to alexoiu
  2. Nope, still no beeps. Nothing that I have tried will give me any beeps. CPU is compatible, just checked at their website. Bad motherboard? It reboots automatically after about 15 secs in an endless loop. I let it sit running for 10 mins with no change.
    Reply to Slick_3
  3. Reply to alexoiu
  4. I went through that entire list and still no beeps! So, I RMA'd and shipped off both mobo and cpu. I will post back here with the new results in a couple weeks. Thanks for your help.
    Reply to Slick_3
  5. No problem.
    Reply to alexoiu
  6. Do you connect beeper to the motherboard right?
    Reply to joan007
Ask a new question Answer

Read More

Displays VGA ASrock