Solved

pc running slow for specs

I think my last post was deleted so if there's anything wrong with my post can the admins tell me instead of just removing it and not telling me anythink.

My PC parts
CPU: AMD Ryzen 7 1700x stock
(I am a user that uses lots of cores so I went for amd because i dont just game on my pc)
GPU: EVGA 1080 ti FE
RAM: 1x8gb 2133mhz
(running in single channel might be a problem but I dont think it will afact fps that much)
SSD: samsung evo 500gb
HDD: 2x 2tb hard drives raid 0
Motherboard: ASUS ROG Strix B350-F GAMING
PSU: corsair HX 850 850w
Cooler: h70
(home made maunting brackit from old am3 brackit to fit am4 no problems I can find with this at this time temps are lower then on my old rig)(if the temp readings are right anyway don't know if there fixed or not)

running 3 1080p moniters 2x144hz 1x60hz (set to use 144hz in settings)


My problem
I posted this forem question not that long ago about what was slowing down my 1080ti. and every one said it was my cpu so I whent out and bought a new cpu motherboard and ram to get more fps out of my 1080ti. but now I am getting lower fps then what I was with my old rig that hade a i7 4790t 2.7-3.8ghz.

I now that the 4790t is about the same speed in games then the ryzen 7 1700x but my problem is on both thes cpus I am getting nowhere near the fps others are getting with the same hardware. for example gta 5 is ment to get 60 to 100 fps on a ryzen 7 1700x but I am getting 40-50 fps. it is not just this game BF4,crisis 3,arma 3 and more are having the same problem. some games run faster on my alienware 13 then my desktop.

in my last post I sead that overwache high setting 150 fps, csgo max settings 230 fps, for honer high setting 90 fps was bad but I know now that this is normal fps for those games.

one added thing changing setting in game dont change my fps at all if I set gta5 to low setting I will get the same fps on max settings in all games.


What I have checked so far.

gpu temps 88c max in game.
cpu temps 57c max in game.
(this is in coretemp I dont now if the temp problems are fixed with amd yet)
cpu clock speed running at stock
gpu core clock 1480mhz stock in game. (this sometimes goes up to 1880)
disk speed is fine
vsync is off in game and in nvidia control panel.
DSR is disabled.
updated bios.
new window 10 home installed with all new drivers.
disabled any programs that can corse fps lose like wallpaper angen or play.tv.
cinebench r15 cpu score 1388

any input will help it might just be me being stopped.

sorry for my bad english.
Reply to xxlegacy
2 answers Last reply Best Answer
More about running slow specs
  1. Best answer
    xxlegacy said:
    I think my last post was deleted so if there's anything wrong with my post can the admins tell me instead of just removing it and not telling me anythink.

    My PC parts
    CPU: AMD Ryzen 7 1700x stock
    (I am a user that uses lots of cores so I went for amd because i dont just game on my pc)
    GPU: EVGA 1080 ti FE
    RAM: 1x8gb 2133mhz
    (running in single channel might be a problem but I dont think it will afact fps that much)
    SSD: samsung evo 500gb
    HDD: 2x 2tb hard drives raid 0
    Motherboard: ASUS ROG Strix B350-F GAMING
    PSU: corsair HX 850 850w
    Cooler: h70
    (home made maunting brackit from old am3 brackit to fit am4 no problems I can find with this at this time temps are lower then on my old rig)(if the temp readings are right anyway don't know if there fixed or not)

    running 3 1080p moniters 2x144hz 1x60hz (set to use 144hz in settings)


    My problem
    I posted this forem question not that long ago about what was slowing down my 1080ti. and every one said it was my cpu so I whent out and bought a new cpu motherboard and ram to get more fps out of my 1080ti. but now I am getting lower fps then what I was with my old rig that hade a i7 4790t 2.7-3.8ghz.

    I now that the 4790t is about the same speed in games then the ryzen 7 1700x but my problem is on both thes cpus I am getting nowhere near the fps others are getting with the same hardware. for example gta 5 is ment to get 60 to 100 fps on a ryzen 7 1700x but I am getting 40-50 fps. it is not just this game BF4,crisis 3,arma 3 and more are having the same problem. some games run faster on my alienware 13 then my desktop.

    in my last post I sead that overwache high setting 150 fps, csgo max settings 230 fps, for honer high setting 90 fps was bad but I know now that this is normal fps for those games.

    one added thing changing setting in game dont change my fps at all if I set gta5 to low setting I will get the same fps on max settings in all games.


    What I have checked so far.

    gpu temps 88c max in game.
    cpu temps 57c max in game.
    (this is in coretemp I dont now if the temp problems are fixed with amd yet)
    cpu clock speed running at stock
    gpu core clock 1480mhz stock in game. (this sometimes goes up to 1880)
    disk speed is fine
    vsync is off in game and in nvidia control panel.
    DSR is disabled.
    updated bios.
    new window 10 home installed with all new drivers.
    disabled any programs that can corse fps lose like wallpaper angen or play.tv.
    cinebench r15 cpu score 1388

    any input will help it might just be me being stopped.

    sorry for my bad english.


    I would start by changing the ram, thats the first thing that stood out to me, you've got this great system and the ram is letting it down, RyZen benefits from faster ram, and 8gb isnt really enough, 2133mhz single channel, thats minimum specs for most games, recommended is 16gb, and you'll want to go for something in the region of 2666mhz min, 2800mhz, 3000mhz or 3200mhz.

    Also your GPU is getting very hot, I wouldnt be surprised if its throttling, ive heard the Founders edition does get pretty hot, not sure what temp it starts to throttle at as I dont use nVidia cards.

    EDIT: ok so I just looked it up, it throttles at 90oC, and complete PC shut down at 105oC, so this could be your problem, the GPU maybe throttling, and that would cause a drop in gaming performance whilst it slows down to cool itself down.
    Reply to Seanie280672
  2. Seanie280672 said:

    I would start by changing the ram, thats the first thing that stood out to me, you've got this great system and the ram is letting it down, RyZen benefits from faster ram, and 8gb isnt really enough, 2133mhz single channel, thats minimum specs for most games, recommended is 16gb, and you'll want to go for something in the region of 2666mhz min, 2800mhz, 3000mhz or 3200mhz.

    Also your GPU is getting very hot, I wouldnt be surprised if its throttling, ive heard the Founders edition does get pretty hot, not sure what temp it starts to throttle at as I dont use nVidia cards.

    EDIT: ok so I just looked it up, it throttles at 90oC, and complete PC shut down at 105oC, so this could be your problem, the GPU maybe throttling, and that would cause a drop in gaming performance whilst it slows down to cool itself down.



    ye I fult the same so I upt the fan speed on my card but I was still getting the same performance.

    I am going to get more ram I only got one stick of ram at furst so I now the modle will work fine beucuse I now ryzen can be funny with ram sometimes. I bet going to duo channal ram will give me a bit of a performance incress.

    update
    so I started to change settings in different drivers and windows and managed to get the fps similar to what overs are getting. I am getting about 10-20 fps less than overs now so I fink I fix my problem. getting more ram and batter coolers will most probably get me the same performance than overs + overclocking. :) thank you
    Reply to xxlegacy
Ask a new question Answer

Read More

FPS